PDA

View Full Version : 9.10 dpi problems (xorg & gdm-cdd)



RobJohnston
April 6th, 2010, 07:20 PM
Hi all,

I'm having a problem with getting mythbuntu to play nice with my LCD TV.

It seems my LCD TV doesn't report its resolution / dpi settings properly and mythbuntu doesn't guess it right.

All the help I've seen seem to involve making changes to xorg.conf or gdm-cdd.conf neither of which I can find on my install of mythbuntu 9.10.

Any ideas on how I can make progress on this?

Thanks, Rob.

superm1
April 7th, 2010, 07:37 AM
Hi all,

I'm having a problem with getting mythbuntu to play nice with my LCD TV.

It seems my LCD TV doesn't report its resolution / dpi settings properly and mythbuntu doesn't guess it right.

All the help I've seen seem to involve making changes to xorg.conf or gdm-cdd.conf neither of which I can find on my install of mythbuntu 9.10.

Any ideas on how I can make progress on this?

Thanks, Rob.
What's your graphics card?

If NVIDIA, there is most certainly " Option "DPI" "100x100"
" which should have been added to your xorg.conf during install. If you are running Intel or AMD, you will probably have to muck with DisplaySize to get it right.

The gdm-cdd.conf solution is no longer valid on 9.10 or later on any hardware.

RobJohnston
April 7th, 2010, 06:28 PM
Thanks for replying.

The thing is I can't find xorg.conf, I'm told it should be:
/etc/X11/xorg.conf
but it's not there!

locate xorg.conf produces only:
/usr/share/man/man5/xorg.conf.5.gz

Any further ideas?

wojox
April 7th, 2010, 06:30 PM
If your running nvidia run:


sudo nvidia-xconfig

Or


sudo Xorg -configure

Should put one in your /root directory which you'll have to mv to /etc/X11

RobJohnston
April 7th, 2010, 06:37 PM
Thanks for the tip.

Should have mentioned it's an intel graphics card.

Rob.