PDA

View Full Version : 10.04 beta 1 wireless and other questions



neednewlaptop
April 3rd, 2010, 03:02 PM
On my new laptop, which came with windows 7, I wanted to give 10.04 beta 1 a try. I downloaded the amd64 alternate (alternate, because I wanted to encrypt home). Pc is an asus k52j laptop with core i3 cpu and ati hd5470 graphics.

1-during install no network devices were found, I can now see that Atheros AR9285 was installed with ath9k driver, but speed is not listed in connection information and the toggle Fn+F2 does not seem to work (toggles for brightness and volume do work), the led in the front panel of the laptop is always on and the network manager applet does not seem to integrate the enable/disable wireless option with the key-toggle

2-when installing grub finds windows vista on 2 partitions, but that is false, these are the recovery partition and the windows partition, which is windows 7, strangely after install is complete it does list windows 7 in the os list

3-for some reason the windows7 partition is auto-mounted, is this by design?

4-I like using aptitude to update, but update manager still seems to use apt-get (need to use apt-get to make update manager notice that it was updated less then one hour ago)

5-when setting visual effect to extra I need to install proprietary ati fglrx driver, which seems to disable the brightness key toggle

Just a few points I wanted to mention. I do like 10.04 so far, the only real issue I have is with the Atheros AR9285 wireless card (1). Help with that would be nice.

6-just noticed that only 3817MB of 4096MB memory are visible, 64 bit hardware and 64 bit os should be able to make use of all memory, or am I forgetting something?

neednewlaptop
April 5th, 2010, 09:30 AM
For the first point I tried installing driver from compat wireless and tried blacklisting ath9k, but this didn't have the desired result.

Anyone?

davidmohammed
April 5th, 2010, 09:40 AM
... presume you've followed something similar as in this thread (http://ubuntuforums.org/showthread.php?t=1286503)?

neednewlaptop
April 5th, 2010, 09:42 AM
You presume correctly.

davidmohammed
April 5th, 2010, 09:49 AM
... is this your bug (https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/535222)? Looks like an ongoing issue.

neednewlaptop
April 5th, 2010, 10:02 AM
I noticed that bug, it is not exactly the same, but close enough. However, this was reported a month ago and has not been assigned, so I do not know if someone is paying attention to it.

davidmohammed
April 5th, 2010, 10:40 AM
If its a kernel issue and the current backports dont work then you are out of luck.

Have you tried ndiswrapper using a windows xp driver?

This link (http://kemovitra.blogspot.com/2009/10/linux-atheros-ar9285-driver-for-toshiba.html) looks promising. I know you are not using a toshiba - but this could work.

Alternatively, given you've got windows 7 - you might be able to steal its .inf file and driver.

neednewlaptop
April 6th, 2010, 03:29 PM
Thanks, I didn't know about ndiswrapper. But will it solve the led being always on and wlan starting on boot or only the connection being bad?

Do I have to blacklist all modules that try to use the atheros card before installing ndiswrapper? I read that if another driver is in use it can cause Ubuntu to freeze.

In lsmod I find the modules below:
ath 9k329077 0
mac80211 237604 1 ath9k
ath 9723 1 ath9k
cfg80211 148386 3 ath9k,mac80211,ath
led_class 3732 3 ath9k,asus_laptop,sdhci

neednewlaptop
April 6th, 2010, 09:30 PM
I found out that the connection isn't all that bad. I have been testing large downloads with firefox that reach 1.2 MB/s which is as it should be, but during such a download both gnome networkmanager and wicd report a 0 kb/s connection (as does iwconfig). So the connection does exist, it just gets reported all wrong.

Btw Fn+F2 now does switch wlan on or off, but the led is always on and wlan is always on at boot.

neednewlaptop
April 8th, 2010, 07:40 PM
I found another known bug relating to the led https://bugs.launchpad.net/ubuntu/+source/linux/+bug/451108

Now I just have to see if there is one for wlan being always on at boot.

Anyone got an idea as to why ubuntu only reports 3817 MB memory instead of 4096 MB which is present:
lshw -C network:
description: System memory
physical id: 0
size: 3817MiB
sudo lshw -C network:
description: System Memory
physical id: 41
slot: System board or motherboard
size: 4GiB

So I'm kind of stuck with points 1 and 6 from the first post in this thread.

neednewlaptop
April 16th, 2010, 07:11 AM
I noticed that even with wlan disabled in bios the led is still always on in linux. Hope the bug is fixed before the final release of 10.04.