PDA

View Full Version : [ubuntu] public dir for samba



Error403
March 28th, 2010, 01:26 PM
Hello,

I know the last samba update did something to my configurations, but I cannot find how to fix it. Here's the setup: I made a softlink to /var/www in my home directory for ease of use. That went pretty smoothly, until recently. I also made a softlink to a second harddrive, wich contains public stuff for my home users (pictures, games, music, etc). that is also not working anymore.

So, before I worsen my setup, does anyone have an idea to make those two softlinks work again? Thanks

I'm running Ubuntu Linux 9.10 and Samba 3.4.

Ryan Dwyer
March 28th, 2010, 01:39 PM
I don't get it. What do softlinks have to do with Samba? Are your softlinks inside your Public folder?

Error403
March 29th, 2010, 10:44 PM
I just dont get it either. The two links are in my home folder


lrwxrwxrwx 1 phil phil 8 2010-02-20 20:30 www -> /var/www

lrwxrwxrwx 1 phil phil 18 2010-01-05 23:19 pub -> /mnt/wdc_data/pub/


And I could swear that it stopped working after an update, because other computers have the same problem. I don't have trouble accessing by ssh, but they wont even appear in ftp.

Ryan Dwyer
March 29th, 2010, 11:18 PM
So if you type cd www, it doesn't work? What about cd /var/www?

EDIT: Nevermind, just noticed you said it works in SSH. If it doesn't work in FTP I'd be looking through the FTP config to see if there are any options for handling symlinks.

Error403
April 1st, 2010, 02:28 AM
There, I fixed it with this, if anyone gets the same problem:


[global]
wide links = yes
unix extensions = no

I got the hint through the logs:

Share 'IPC$' has wide links and unix extensions enabled. These parameters are incompatible. Wide links will be disabled for this share.



It's supposed to be a "feature" but is in fact a security issue

http://bbs.archlinux.org/viewtopic.php?id=92183

marslin
April 1st, 2010, 05:50 AM
Thanks. I met same problem and fixed by adding the settings in smb.conf

http://ubuntuforums.org/showthread.php?p=9058590&posted=1#post9058590