PDA

View Full Version : Screensaver Not Working



tracyandskye
March 27th, 2010, 08:28 PM
In Applications > Settings > Screensaver, I set to activate after idle for 1 minute. The screensaver I choose shows OK & the preview works, but it never comes on.

I have loaded Gnome on this machine as well (I'm not using it) and if I switch to a Gnome session the screensaver works properly.

pu15e
March 27th, 2010, 11:01 PM
It's xscreensaver that doesn't work. Switch to gnome-screensaver - it's going to become the default anyways ;-)

Cheers,
Mattt.

tracyandskye
March 27th, 2010, 11:33 PM
When I look in Synaptic, xscreensaver is not installed & gnome-screensaver is, though I did see xscreensaver-gl & xscreensaver-data installed.

williammanda
March 28th, 2010, 06:29 AM
When I look in Synaptic, xscreensaver is not installed & gnome-screensaver is, though I did see xscreensaver-gl & xscreensaver-data installed.

Did you get this issue resolved? I have the same issue.

superm1
March 28th, 2010, 06:32 AM
In Applications > Settings > Screensaver, I set to activate after idle for 1 minute. The screensaver I choose shows OK & the preview works, but it never comes on.

I have loaded Gnome on this machine as well (I'm not using it) and if I switch to a Gnome session the screensaver works properly.

During the 9.10 development cycle the gnome-screensaver guys changed the API they use to detect an inactive sesssion to something that only works on gnome. We didn't get wind of this until too late, so the screensaver doesn't work for 9.10.

For 10.04, we started installing xscreensaver instead, which still works with XFCE.

Bluberri
March 28th, 2010, 08:05 AM
During the 9.10 development cycle the gnome-screensaver guys changed the API they use to detect an inactive sesssion to something that only works on gnome. We didn't get wind of this until too late, so the screensaver doesn't work for 9.10.

For 10.04, we started installing xscreensaver instead, which still works with XFCE.

Ok, so the resolution is to remove gnome-screensaver completely?

FYI, I am running the netbook edition of 10.04 and have the same issue.

superm1
March 28th, 2010, 08:06 AM
If you are running a gnome environment (such as UNE), you should continue to use gnome-screensaver generally. I think there is a different bug about it not working there though too.

williammanda
March 28th, 2010, 02:02 PM
So there is no screensaver possibility using mythbuntu 9.10?

tracyandskye
March 28th, 2010, 02:54 PM
Yes, my question also.

tracyandskye
March 28th, 2010, 02:55 PM
Yes, my question also. I really want to have the picture slideshow on our TV.

pu15e
March 29th, 2010, 12:29 AM
Oops. My bad - when posting in the early AM hours, I really should double-check the subject matter...

As stated, gnome-screensaver is what fails to work. xscreensaver does. We run it on a pair of 9.10 Mythbuntu boxes to run a photo slideshow during idle times (better than a static menu in case the connected TV has been left on).

Cheers,
Mattt.

tracyandskye
March 29th, 2010, 02:20 PM
OK so I assume I want to remove gnome-screensaver & install xscreensaver. But when I select removal for gnome-screensaver in Synaptic, it says it will remove mythbuntu-desktop.

I can try just installing xscreensaver but I don't know if having both installed will mess anything up.

Bucky Ball
June 22nd, 2011, 02:31 PM
Get anywhere with this? Having same issue in 10.04 upgrade.

fullmoonguru
June 22nd, 2011, 02:46 PM
Can't remember. I switched to Ubuntu 10.04 server & loaded myth on it long ago. No problems.

Bucky Ball
June 22nd, 2011, 03:21 PM
Cheers. Odd. Xscreensaver is not installed but that pops up now after about 10 minutes rather than the gnome screensaver which is set to go off after 1 minute. Seems to be ignoring that completely now after my tweakings.