PDA

View Full Version : smb shares to windows machine: can't get write permission



rienzio
March 23rd, 2010, 04:51 AM
hello, trying to copy music to my mythbox. I can share /var/lib/mythtv/music, but it is a read-only share. When I try to change permissions, i get the message that it is owned by "mythtv" and I can't change permissions.

Your help is appreciated, as always!

stevanbt
March 23rd, 2010, 01:16 PM
Hi,
Have you checked the permissions in your samba config file on the ubuntu machine? I'm not at my ubuntu box now so can't say what's in mine, but have a look in /etc/samba/smb.conf for the permissions.

Thanks, Steve.

singedwings
March 23rd, 2010, 03:24 PM
One way is to open a terminal and enter
sudo nautilusBe careful as you can do damage if you delete things in this mode as none of the system files will be protected! Right click on the folder you want to share and select sharing options. You will now be able to share the folder.

rienzio
March 23rd, 2010, 06:27 PM
singedwings, thanks! That did the trick, and I will use judiciously.

Steve, I opened my smb.conf, and didn't find anything immediately obvious to this n00b. But I do understand a bit more about how samba works. Thanks!