PDA

View Full Version : [SOLVED] XP BSOD after Ubuntu Install



ChewyNougat
March 22nd, 2010, 01:20 PM
I've had many installation issues that I won't go into here, and have had to reinstall several times. All I'm trying to do is get an XP installation dual-booting with 9.10.

1. My hard drive partitions are:
120 GB NTFS (with boot flag) for Windows
40GB EXT4 for 9.10 (/)
8GB Swap
The rest (around 220GB) EXT3 for /home

2. I install Windows, and during the windows partitioner it doesn't see the 3 other partitions on the drive, just the NTFS partition, which is odd. I install Windows on that partition, and confirm that I am able to do a cold boot into it.

3. I boot up a 9.10 CD, and all looks as it should. I install Ubuntu in the partitions as outlined above, and it doesn't have any issues.

4. I can now reboot into Ubuntu without issue. When booting into Windows, I get the startup screen with the blue "progress" ticker, which displays for about 2 seconds, then I get a BSOD. The message refers to making sure the hard drives are "partitioned and terminated correctly" and whatnot. If I didn't know any better (and I obviously don't), I'd accuse Ubuntu of bjorking my clean Windows install.

Thanks in advance for any help!

prodigy_
March 22nd, 2010, 02:55 PM
More info needed. First, do
sudo fdisk -l and post the output. Second, post your grub menu (it's either in /boot/grub/menu.lst or in /boot/grub/grub.cfg).

Third, use Disk Utility (System/Administration/Disk Utility) to check SMART data on your HDD. If there are any reallocated sectors, you possibly have a hardware problem.

phillw
March 22nd, 2010, 02:58 PM
Hi

No, ubuntu is not 'beating up' your windows installation ;-)

Win can not see ext3 / ext4 / swap etc partitions which is why it only sees the ntfs one when you install.

Try putting Win back on the MBR (This make your Ubuntu area vanish, but will not harm it)

http://ubuntuforums.org/showthread.php?t=1014708

Once Win has settled down, re-visit that thread and put Grub back on.

If you are still having problems, the only other issue that I have seen is if Win is installed on extended partitions - I always use sda1 for Win dual boots, but sda1, sda2, sda3 & sda4 should all be okay to use.

Regards,

Phill.

ChewyNougat
March 22nd, 2010, 10:14 PM
Here are the results from fdisk -l and grub.cfg.



Disk /dev/sda: 400.1 GB, 400088457216 bytes
255 heads, 63 sectors/track, 48641 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000001

Device Boot Start End Blocks Id System
/dev/sda1 * 1 16708 134206978+ 7 HPFS/NTFS
/dev/sda2 16709 21571 39062047+ 83 Linux
/dev/sda3 21572 22544 7815622+ 82 Linux swap / Solaris
/dev/sda4 22545 48641 209624152+ 83 Linux

Disk /dev/sdc: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xfcdc417f

Device Boot Start End Blocks Id System
/dev/sdc1 1 9729 78148161 42 SFS

Disk /dev/sdd: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x4280bb6b

Device Boot Start End Blocks Id System
/dev/sdd1 * 1 14593 117218241 7 HPFS/NTFS

Disk /dev/sdb: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x3638126c

Device Boot Start End Blocks Id System
/dev/sdb1 1 9729 78148161 42 SFS
ubuntu@ubuntu:~$






#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s /boot/grub/grubenv ]; then
have_grubenv=true
load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
saved_entry=${prev_saved_entry}
save_env saved_entry
prev_saved_entry=
save_env prev_saved_entry
fi
insmod ext2
set root=(hd0,2)
search --no-floppy --fs-uuid --set bb5fcee1-3fc6-40e2-a28a-a43e93b0a75c
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=640x480
insmod gfxterm
insmod vbe
if terminal_output gfxterm ; then true ; else
# For backward compatibility with versions of terminal.mod that don't
# understand terminal_output
terminal gfxterm
fi
fi
if [ ${recordfail} = 1 ]; then
set timeout=-1
else
set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/white
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry "Ubuntu, Linux 2.6.31-20-generic-pae" {
recordfail=1
if [ -n ${have_grubenv} ]; then save_env recordfail; fi
set quiet=1
insmod ext2
set root=(hd0,2)
search --no-floppy --fs-uuid --set bb5fcee1-3fc6-40e2-a28a-a43e93b0a75c
linux /boot/vmlinuz-2.6.31-20-generic-pae root=UUID=bb5fcee1-3fc6-40e2-a28a-a43e93b0a75c ro quiet splash
initrd /boot/initrd.img-2.6.31-20-generic-pae
}
menuentry "Ubuntu, Linux 2.6.31-20-generic-pae (recovery mode)" {
recordfail=1
if [ -n ${have_grubenv} ]; then save_env recordfail; fi
insmod ext2
set root=(hd0,2)
search --no-floppy --fs-uuid --set bb5fcee1-3fc6-40e2-a28a-a43e93b0a75c
linux /boot/vmlinuz-2.6.31-20-generic-pae root=UUID=bb5fcee1-3fc6-40e2-a28a-a43e93b0a75c ro single
initrd /boot/initrd.img-2.6.31-20-generic-pae
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Microsoft Windows XP Professional (on /dev/sda1)" {
insmod ntfs
set root=(hd0,1)
search --no-floppy --fs-uuid --set 8ab8035bb80344e3
drivemap -s (hd0) ${root}
chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###


I'm going to try the FixMBR solution now, thanks guys!

ChewyNougat
March 22nd, 2010, 10:32 PM
UPDATE:

I booted from the Windows XP CD and ran CHKDSK. It said "the volume appears to have one or more unrecoverable errors" or something similar. I then ran FIXMBR, which blew away grub (as expected), but I still get the Windows blue screen on boot.

Going to try to restore grub so I can at least boot into Ubuntu.

Any other suggestions are greatly appreciated!

ChewyNougat
March 23rd, 2010, 01:48 AM
Another update, for anyone that's still watching this thread...

Ubuntu says that the hard drive in question is 400GB. I've always thought this was odd, but I trusted it.

In my most recent test attempt, I wiped the drive completely clean. Deleted all partitions and everything. I booted into the Windoze installer, and what does it say? It still reports the drive as being 131GB. Something fishy is definitely going on here.

131GB is the exact size windows ever saw from this drive, even when it was carved into 4 partitions and Ubuntu was installed on the latter 3. I'm really, really confused now.

ChewyNougat
March 23rd, 2010, 02:18 AM
New developments:

The drive is actually 400GB, as Ubuntu has said all along. The BIOS sees 400GB and Ubuntu does too, but Windows refuses to see more than 131GB during installation when the drive is completely blank.

Megafag
March 23rd, 2010, 03:56 AM
Windows refuses to see more than 131GB during installation when the drive is completely blank.

Thats coz it sucks ;)

Have the BSOD's stopped?

prodigy_
March 23rd, 2010, 03:57 AM
Hmm. What version of XP are you trying to install? Because what you've got sounds awfully like pre-SP1 XP "137GB barrier" problem.

A possible workaround is to d/l some XP distributive with integrated SP2 or SP3, burn it in on a CD and install from that CD. (Just be careful about what you're downloading - don't trust any unofficial builds. I can PM you links to official RTM images.)

Megafag
March 23rd, 2010, 04:00 AM
pre-SP1 XP "137GB barrier" problem.

Where did you get the install disk from? did it come with your computer?

ChewyNougat
March 23rd, 2010, 01:09 PM
You guys are exactly right. I thought the issue seemed exceptionally weird, as I've been doing dual-boot installs of XP and Ubuntu for several years and haven't run into this issue before. The variable that changed was the XP install disc; I found an old one that was pre-service pack.

Right after posting last, I called a friend and he pointed me in the right direction (the same direction you guys were pointing).

So I wiped the drive clean and installed XP, then installed SP 1&2, installed Ubuntu, and LIFE IS GOOD AGAIN!

Thank heavens. That was starting to get old. Thanks for everyone's help!