PDA

View Full Version : [ubuntu] Apache2 update breaks PHP?



pinn8
March 13th, 2010, 03:03 AM
I'm running 8.04 Server LTS and havig a problem with the most recent apache2 package updates. The updates (version 2.2.8-1ubuntu0.15) break php5. All of my PHP pages show up in Firefox with a prompt for me to download an object of type application/x-httpd-php.

Looking at the install logs for the package updates, it appears that php5-mysql and libapache2-mod-php5 are uninstalled by the apache2 update, and never reinstalled. Simply re-installing these modules with apt-get does not fix the problem.

Can anybody offer any suggestions for how to get my LAMP stack working again?

pinn8
March 15th, 2010, 12:47 AM
bump. Any ideas?