PDA

View Full Version : [SOLVED] move Maximize,Minimize,Close to right side?



Zaphrod
March 7th, 2010, 02:58 PM
Hi,

I have been trying to get the window buttons moved back to the right side since the last update but they won't move. I have changed the button layout settings in gconf-editor to menu:minimize,maximize,close but it doesn't work, I have rebooted and checked the settings have remained as I set them and they do but the buttons stubbornly stay on the left. I have tried running gconf-editor with and without gksudo.

Any Ideas?

nilarimogard
March 7th, 2010, 03:18 PM
":minimize,maximize,close" will give you a broken metacity because of the border around the maximize button. So you must put the maximize before minimize. Still, it should have worked anyway.

Try running this in a terminal and see if anything changes:

gconftool-2 --type string --set /apps/metacity/general/button_layout "menu:maximize,minimize,close"

Zaphrod
March 7th, 2010, 04:01 PM
That did the trick thanks very much.

kastlemaster
March 7th, 2010, 07:40 PM
Thanks, that worked very well. :popcorn:

Ubuntu 10.4 amd64

RedG
March 26th, 2010, 01:21 PM
Thanks!
I had the colon on the wrong side of the list of bottons.
ie.
was
/apps/metacity/general/button_layout "maximize,minimize,spacer,close:"
when corrected
/apps/metacity/general/button_layout ":maximize,minimize,spacer,close"

nilarimogard
March 26th, 2010, 10:38 PM
The latest version of the themes also supports :minimize,maximize,close ... finally!

plapczynski
April 9th, 2010, 11:07 PM
Thanks! That was driving me nuts!

superstargoddess
April 10th, 2010, 06:48 AM
Awesome, thanks! This was just what I was looking for! I can't stand that stuff being on the left side!

Mies
April 29th, 2010, 02:42 PM
Thanks, drove me mental as well.

vittalp88
May 3rd, 2010, 05:29 PM
Thank you.

jahn surf irie
May 3rd, 2010, 11:33 PM
nilarimogard > thanks much, that was driving me nuts as well!! :D

thefallofroy
June 21st, 2010, 07:39 AM
Thanks a million nilarimogard!

felixq78
June 9th, 2011, 10:50 AM
":minimize,maximize,close" will give you a broken metacity because of the border around the maximize button. So you must put the maximize before minimize. Still, it should have worked anyway.

Try running this in a terminal and see if anything changes:

gconftool-2 --type string --set /apps/metacity/general/button_layout "menu:maximize,minimize,close"

And a thank you from me as well.
Cheers

emma00
June 9th, 2011, 11:04 AM
My minimize,maximize and close has gone after changing some compiz settings i have unchecked them but these are not coming back for any menu any suggestion????

Copper Bezel
June 9th, 2011, 12:00 PM
Are the buttons gone, or is the entire title bar gone?

emma00
June 9th, 2011, 01:43 PM
only these three buttons are gone

Copper Bezel
June 9th, 2011, 01:49 PM
Did you try running the command above?

emma00
June 9th, 2011, 04:19 PM
yup done this but no luck:(

felixq78
June 9th, 2011, 10:36 PM
":minimize,maximize,close" will give you a broken metacity because of the border around the maximize button. So you must put the maximize before minimize. Still, it should have worked anyway.

Try running this in a terminal and see if anything changes:

gconftool-2 --type string --set /apps/metacity/general/button_layout "menu:maximize,minimize,close"

I've discovered a neat trick with Ubuntu 11.04.
This [minimize,maximize,close] operation won't work with 11.04 but if you log out of Unity and then back into Gnome classic it will work. Then log back into Unity and the buttons move from side to side when appropriate. If Unity needs the buttons on the left because there's other stuff on the right e.g. Calender/Time/login name, whatever,.. it places the buttons on the left, but if there's no need it automatically places them on the right.
Cool, eh ?

KirbySmith
June 12th, 2011, 05:31 PM
Forced to upgrade from 9.10 to 10.04.2, I wish to bestow a kudos upon nilarimogard for providing the fix for this introduced inefficiency. Maybe someone involved in Office 2007 ribbon development was allowed to meddle with Ubuntu.

kirby