PDA

View Full Version : [SOLVED] Newb has conflicting mysql(s)



woodsonoversoul
March 5th, 2010, 04:46 PM
Hello all,
I've been working with a database using xampp for a while now; until recently, when I had to take a break. During that break I began working with rails for the first time. I believe that during my rails setup I installed another version of mysql. When I run:

sudo /opt/lampp/lampp start
to begin working with my xampp database, I get:

Starting XAMPP for Linux 1.6.8a...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Another MySQL daemon is already running.
XAMPP: Starting ProFTPD...
XAMPP for Linux started.


How can I access my old database?

fwiw I setup rails using netbeans

woodsonoversoul
March 5th, 2010, 05:02 PM
Solved.

sudo mysqladmin shutdown

then restart xampp

cdenley
March 5th, 2010, 06:02 PM
I would suggest you stick to the ubuntu software repositories in the future to avoid these conflicts and to ensure your software is secure and stable.