PDA

View Full Version : [SOLVED] Upgrade to Lucid on 5,3 keyboard not responding



viktara
March 5th, 2010, 10:16 AM
Hi,

I upgraded to Lucid with update manager last night.

Everything seemed to go ok - except now the keyboard has stopped working!

Anyone seen this already?

TIA


Vik

alpine4
March 6th, 2010, 02:37 AM
Yeah, I'm currently having the same issue on my iMac. Keyboard only works for about 2 seconds after plugging it in, then just stops :-?

viktara
March 6th, 2010, 04:54 PM
According to this bug:
https://bugs.launchpad.net/bugs/513932

It appears that the problem is caused by the mouseemu package.

I logged in using the virtual keyboard, removed that package - and my keyboard is now working again :)

alpine4
March 6th, 2010, 07:49 PM
Sweet! That seemed to do the trick. Thanks!

robyinno
March 11th, 2010, 09:55 AM
On my PowerBook 12 1Ghz is solved in the same way!

Thanks

nitrofurano
March 26th, 2010, 10:57 AM
@alpine4 this is not a trick, since mouseemu on macs are very important... :(

kfsone
March 26th, 2010, 11:16 AM
I'm running 10.4 in a VMWare environment, I haven't rebooted the virtual machine in a while, but I just had to, and I had the keyboard-not-responding issue;

Additionally: The on-screen keyboard app kept crashing as soon as it opened until I booted off the install DVD with the onscreen keyboard set at the initial menu.

I don't have mouseemu installed...

padangbond
April 16th, 2010, 07:27 AM
I've also found out that if you have a line on /etc/modprobe.d/options.conf:

options hid pb_fnmode=2

Change it to:

#options hid pb_fnmode=2

And save. If you have no access to your keyboard, ssh into your machine and change it that way. Suddenly all your usb will just work!