PDA

View Full Version : [ubuntu_studio] 17:34:42.096 JACK has crashed



SagnaB
February 25th, 2010, 09:33 AM
Hi all,
I have this persistent error with jack that I cannot seem to be able to rectify for the life of me. I've searched the forum but unfortunately not found this exact same error. Found very similar post, though none have help my situation. Jack will not start. I have posted the contents of 'messages' bellow. I previously had UbStu 9.04 installed and jack worked close to perfectly, after this new install of 9.10, it just doesn't start.

I cant make sense of this


17:34:38.924 Patchbay deactivated.
17:34:38.933 Statistics reset.
17:34:39.020 ALSA connection graph change.
17:34:39.225 ALSA connection change.
17:34:41.136 Startup script...
17:34:41.142 artsshell -q terminate
sh: artsshell: not found
17:34:41.545 Startup script terminated with exit status=32512.
17:34:41.546 JACK is starting...
17:34:41.546 /usr/bin/jackd -R -t1000 -dalsa -dhw:0 -r44100 -p256 -n2 -Xseq
17:34:41.558 JACK was started with PID=3028.
no message buffer overruns
jackd 0.116.1
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
loading driver ..
apparent rate = 44100
creating alsa driver ... hw:0|hw:0|256|2|44100|0|0|nomon|swmeter|-|32bit
control device hw:0
17:34:42.094 JACK was stopped successfully.
17:34:42.095 Post-shutdown script...
17:34:42.095 killall jackd
17:34:42.096 JACK has crashed.
jackd: no process found
17:34:42.507 Post-shutdown script terminated with exit status=256.
17:34:43.664 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Thank you all

EDIT:: I uncheck realtime in setup and it works. My kernel is: 2.6.31-9-rt. I am a member of the audio group. How can I enable jack to run with realtime?

trulan
February 25th, 2010, 01:19 PM
Edit this file:

sudo gedit /etc/security/limits.confand add this line:

@audio - rtprio 99That should fix it right up. While you're editing that file, you can also add these lines:

@audio - memlock unlimited
@audio - nice -10If you don't like memlock unlimited, you can use a number (in KB) from 1/2 to 3/4 of your system memory.

You may need to reboot or log out and in for this to take affect, I'm not sure.

AutoStatic
February 25th, 2010, 01:30 PM
You may need to reboot or log out and in for this to take affect, I'm not sure.Log out and in again should suffice. And setting a nice value is not necessary when using rtprio.

SagnaB
February 26th, 2010, 03:05 PM
Edit this file:

sudo gedit /etc/security/limits.confand add this line:

@audio - rtprio 99That should fix it right up. While you're editing that file, you can also add these lines:

@audio - memlock unlimited
@audio - nice -10If you don't like memlock unlimited, you can use a number (in KB) from 1/2 to 3/4 of your system memory.

You may need to reboot or log out and in for this to take affect, I'm not sure.

They're already in my limits.conf file and I have rebooted and tried again; same errors.
Occasionally with realtime enabled in setup, jack completely freezes (gui fades to grey).

It works fine with realtime disabled, not my ideal setup though.

AutoStatic
February 26th, 2010, 03:09 PM
Is your account a member of the 'audio' group?

SagnaB
February 26th, 2010, 03:39 PM
yeah i am

trulan
February 26th, 2010, 06:17 PM
Have you checked your CPU scaling? Problems with jack can arise when the CPU is set to on-demand. An easy fix for this is to use the gnome-panel CPU scaling gadget, use one for each CPU core.

Also, have you updated your rtirq script? A key funtion (the real time clock, or rtc) is not prioritized properly in Karmic and this can also cause problems when using real time. A fix for this is described here:
http://ubuntuforums.org/showpost.php?p=8347114&postcount=5
Ignore the part about ohci1394 since you are not using firewire.

What happens is, Jack and your soundcard get set to a very high priority (70, 80, or even higher), but the real time clock (which needs an even higher priority) gets missed and is only given a priority of 50. This causes instability, I've heard reports that Jack won't run if the real-time priority is over sixty or so.

SagnaB
February 27th, 2010, 04:08 PM
Ok. I have already been using the cpu-scaling gadget and I set it to 100%.
I just then updated rtirq using the steps provided @ the link. Rebooted but Jack will still not operate with realtime selected.
Posted a copy of the 'messages' box if that helps anyone get it (though, I think it's the same):



01:31:49.148 Patchbay deactivated.
01:31:49.177 Statistics reset.
01:31:49.268 ALSA connection graph change.
01:31:49.449 ALSA connection change.
01:31:52.209 Startup script...
01:31:52.209 artsshell -q terminate
sh: artsshell: not found
01:31:52.614 Startup script terminated with exit status=32512.
01:31:52.614 JACK is starting...
01:31:52.615 /usr/bin/jackd -R -t1000 -dalsa -dhw:0 -r44100 -p256 -n2 -Xseq
01:31:52.627 JACK was started with PID=2708.
no message buffer overruns
jackd 0.116.1
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
loading driver ..
apparent rate = 44100
creating alsa driver ... hw:0|hw:0|256|2|44100|0|0|nomon|swmeter|-|32bit
control device hw:0
01:31:53.151 JACK was stopped successfully.
01:31:53.152 Post-shutdown script...
01:31:53.152 killall jackd
01:31:53.153 JACK has crashed.
jackd: no process found
01:31:53.562 Post-shutdown script terminated with exit status=256.
01:31:54.718 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.

AutoStatic
February 27th, 2010, 05:28 PM
What card are you using? What's the output of aplay -l?

SagnaB
February 27th, 2010, 05:59 PM
What card are you using? What's the output of aplay -l?


**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC883 Analog [ALC883 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC883 Digital [ALC883 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0


This shouldn't really be the issue, I do not assume, as I had it all running well with realtime on 9.04. Unless my card/chip is no longer fully supported...

AutoStatic
February 27th, 2010, 06:30 PM
I have a hunch that the ALSA HDA Intel module does not work properly with the Karmic realtime kernel. I have the exact same issues namely on my notebook that has a HDA Intel codec.

SagnaB
February 28th, 2010, 02:33 PM
Ah yes, well that might explain it. Would upgrading ALSA to 1.0.22.1 help at all?

AutoStatic
February 28th, 2010, 03:23 PM
No idea. Wouldn't try it though, it could crash your complete sound stack, unless you know what you're doing. There are backported drivers available (linux-backports-modules-alsa-karmic-generic), but only for the generic kernel. You could try those and test JACK with the generic kernel. The Karmic generic kernel is pretty much up to par when it comes to realtime audio processing.

max1000
February 28th, 2010, 08:38 PM
I have been deal with jack and I have the same problems.

I discover that the jackd is not running, jack deamon I think. When I start with "/etc/init.d/jackd start" says that I have to edit "/etc/default/jackd", also jackd needs user "fred" to run

Original contents of "/etc/default/jackd":
$more /etc/default/jackd
# Set to "yes" to start jackd at boot
START_DAEMON=no

# The jackd process will run under this user
USER=fred

# Options to pass to jackd
OPTIONS="-R -d alsa -d hw"

Finaly I can start jackd with /etc/init.d/jackd , then if I start JackControl it opens started, like I click in start button. If I stop jackControl then I cannot start again.

It's seems a config problem with jack, I tried with two diferent sound cards.


thanks.

AutoStatic
March 1st, 2010, 09:47 AM
Hello max1000, in this case it's not a configuration problem. Besides, it makes no difference if you run the init script or run jackd in a user session.