PDA

View Full Version : [ubuntu] Packetfence



fcastillo4969
February 23rd, 2010, 10:56 PM
I am new to packtefence. I installed packetfence 1.8.7 to ubuntu desktop. After the installation of Apache, php, snort, perl, and packetfence, as i start i recieve this error.:confused:

packetfencesyntax error at /usr/local/pf/bin/pfcmd line 58, near "use Readonly."

It is frustrating ](*,)

Any Ideas????

tonymaro
October 25th, 2010, 12:14 AM
For anyone else with this issue (I assume the poster either solved or gave up by now) it means you're missing the Perl module.

Ubuntu was missing a LOT of perl modules. I finally got fedup and started using apt-get with regex to install most all the available perl modules in the repository.

dcstar
December 21st, 2010, 03:44 AM
For anyone else with this issue (I assume the poster either solved or gave up by now) it means you're missing the Perl module.

Ubuntu was missing a LOT of perl modules. I finally got fedup and started using apt-get with regex to install most all the available perl modules in the repository.

For those who wants to install Packetfence on Ubuntu, I just came across this HOWTO:

http://www.linux.com/learn/tutorials/386610:install-packetfence-for-powerful-network-access-control