PDA

View Full Version : [ubuntu] Belkin F6D4050



stephenmac7
February 21st, 2010, 09:03 PM
I have a Belkin F6D4050 and I also have ndiswrapper and I would like to know how to use the adapter in ubuntu

jpl888
February 21st, 2010, 10:08 PM
Can you post the output of
lsusb so we can see what chipset it is and help you?

stephenmac7
February 21st, 2010, 10:32 PM
where do I put the code?

jpl888
February 21st, 2010, 10:40 PM
In a terminal.

e.g. Applications -> Accessories -> Terminal

stephenmac7
February 21st, 2010, 10:47 PM
It says this-
No command '1susb' found, did you mean:
Command 'lsusb' from package 'usbutils' (main)
1susb: command not found

jpl888
February 21st, 2010, 10:54 PM
Type
sudo apt-get install usbutils

and try the original command again.

stephenmac7
February 21st, 2010, 10:58 PM
It says I already have it

jpl888
February 21st, 2010, 11:04 PM
I think you must've typed a one instead of a letter l the first time you typed "lsusb". Try it again with a letter l.

stephenmac7
February 21st, 2010, 11:08 PM
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 050d:935a Belkin Components
Bus 001 Device 002: ID 04b4:6560 Cypress Semiconductor Corp. CY7C65640 USB-2.0 "TetraHub"
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 046d:c408 Logitech, Inc. Marble Mouse (4-button)
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

stephenmac7
February 21st, 2010, 11:08 PM
I have a Logitech Mouse

stephenmac7
February 21st, 2010, 11:14 PM
I removed a usb now it says

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 005: ID 050d:935a Belkin Components
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 046d:c408 Logitech, Inc. Marble Mouse (4-button)
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

jpl888
February 21st, 2010, 11:18 PM
According to a few searches the chipset on that Belkin is an Ralink 2870. See the below link for a how to, post back if you're stuck.

http://ubunturt2870.pbworks.com/FrontPage

stephenmac7
February 21st, 2010, 11:40 PM
I get a few errors like error [1] & error [2]

jpl888
February 21st, 2010, 11:51 PM
Perhaps you could ellaborate a bit?

Is there no more accompanying information than that?

stephenmac7
February 21st, 2010, 11:53 PM
make -C /home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux -f Makefile.6 install
mkdir: cannot create directory `/etc/Wireless': File exists
make[1]: Entering directory `/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux'
rm -rf /etc/Wireless/RT2870STA
mkdir /etc/Wireless/RT2870STA
cp /home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/RT2870STA.dat /etc/Wireless/RT2870STA/.
install -d /lib/modules/2.6.31-20-generic/kernel/drivers/net/wireless/
install -m 644 -c rt2870sta.ko /lib/modules/2.6.31-20-generic/kernel/drivers/net/wireless/
install: cannot stat `rt2870sta.ko': No such file or directory
make[1]: *** [install] Error 1
make[1]: Leaving directory `/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux'
make: *** [install] Error 2


How about that?

stephenmac7
February 21st, 2010, 11:56 PM
Thank you so much I value your time. :)

jpl888
February 21st, 2010, 11:58 PM
cannot stat `rt2870sta.ko': No such file or directory

Looks to be the main problem.

That is the module that should have been built by the preceding build process.

Perhaps there was a build error earlier on.

Could you post the output of the previous
sudo make

command?

stephenmac7
February 22nd, 2010, 12:04 AM
sudo make:
make -C tools
make[1]: Entering directory `/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory `/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/tools'
/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/tools/bin2h
cp -f os/linux/Makefile.6 /home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux/Makefile
make -C /lib/modules/2.6.31-20-generic/build SUBDIRS=/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.31-20-generic'
CC [M] /home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux/../../os/linux/rt_linux.o
/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux/../../os/linux/rt_linux.c: In function ‘RtmpOSIRQRequest’:
/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux/../../os/linux/rt_linux.c:1068: warning: unused variable ‘net_dev’
/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux/../../os/linux/rt_linux.c: In function ‘RtmpOSTaskAttach’:
/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux/../../os/linux/rt_linux.c:1282: warning: unused variable ‘pid_number’
/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux/../../os/linux/rt_linux.c: In function ‘RtmpOSNetDevAttach’:
/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux/../../os/linux/rt_linux.c:1624: error: ‘struct net_device’ has no member named ‘open’
/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux/../../os/linux/rt_linux.c:1625: error: ‘struct net_device’ has no member named ‘stop’
/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux/../../os/linux/rt_linux.c:1626: error: ‘struct net_device’ has no member named ‘hard_start_xmit’
/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux/../../os/linux/rt_linux.c:1627: error: ‘struct net_device’ has no member named ‘do_ioctl’
/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux/../../os/linux/rt_linux.c:1633: error: ‘struct net_device’ has no member named ‘get_stats’
/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux/../../os/linux/rt_linux.c:1667: error: ‘struct net_device’ has no member named ‘validate_addr’
make[2]: *** [/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux/../../os/linux/rt_linux.o] Error 1
make[1]: *** [_module_/home/stephen/Downloads/2009_0820_RT2870_Linux_STA_V2.2.0.0/os/linux] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.31-20-generic'
make: *** [LINUX] Error 2

stephenmac7
February 22nd, 2010, 12:04 AM
Sudo make: is not part of the code also how do you make those code boxes?

jpl888
February 22nd, 2010, 12:25 AM
Click on the # sign in the editor window.

That first set of instructions doesn't look that good try these instead:-

http://ubuntuforums.org/showthread.php?t=1342593

I'm pretty technical and I don't like trying to setup wireless cards that don't have a decent native driver in Linux. My advice to you would be to get another card with a different chipset.

If you post what makes and models of cards are available to you to buy I can tell you what will work well.

jpl888
February 22nd, 2010, 12:27 AM
Have to go to bed and clean up the kitchen not necessarily in that order. Will pick it up tomorrow.