PDA

View Full Version : [ubuntu] Close / Minimize / Maximize buttons desappeared at 16 Color Depth



bhencetotozo
February 11th, 2010, 04:15 PM
!!HELP!! Close, Minimize, Maximize Buttons Desapear at 16 Color Depth
Hello there guys, thank you for taking time to read this:

Everything worked 100% great untill I change color depth to 16 bits.
I do not want 24 Bits, I want 16 Bits. I have good reasons.

Never had this problem in Gutsy 7.10 ...
I deeply regret in upgrading to 9.10 ... Why did I upgrade? :'(

----------------
My video card:
Gforce 7950 GX2

----------------
Changes to xorg.conf file:
Firstly, I saved it at 16 color depth with the sudo nvidia-settings and by clicking on the save to xorg.conf file Button. Rebooted computer.......

It worked, saved file, and I got the following bugs:

*Cannot move windows by dragging their title bars.
*Cannot see close "X" Button in the title bar.
*Cannot see Minimize Button in the title bar.
*Cannot see Maximize Button in the title bar.

Went back to 24 bits and problem got resolved.

Then i tryed:
I did sudo gedit xorg.conf
I changed all the 24's with 16's ...
Rebooted computer.......
It works GOOD... BUT:
I got the same bugs from before. I will retype them below

*Cannot move windows by dragging their title bars.
*Cannot see close "X" Button in the title bar.
*Cannot see Minimize Button in the title bar.
*Cannot see Maximize Button in the title bar.


My xorg.conf file:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Sun Feb 1 20:21:04 UTC 2009


Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
# generated from default
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Philips 190S"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 76.0
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7950 GX2"
BusID "PCI:6:0:0"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Monitor0"
DefaultDepth 16
EndSection

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 16
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "1280x1024 +0+0; nvidia-auto-select +0+0"
SubSection "Display"
Depth 16
EndSubSection
EndSection

---------------------------------------------
bhencetotozo is online now Report Post Edit/Delete Message

flippo
February 11th, 2010, 05:11 PM
When you say the buttons vanished, do you mean just the buttons, or the entire window border, as if your window manager crashed?

bhencetotozo
February 11th, 2010, 09:29 PM
When you say the buttons vanished, do you mean just the buttons, or the entire window border, as if your window manager crashed?


Because of the theme it is hard to tell... but I believe it is the whole window border... because... I cant even Drag the window with out holding ALT... so I think you are right... it is the whole border.

I mean... If it is in 24 color depth.. everything is fine...
but in 16 color depth, it won't work...

In gutsy 7.10 this was not an issue... and the desktop effects will run smoother at 16 Bits color depth when IM running toomany applications... I hate Video LAG... and at 16 Bit color depth I am sure My video card will handle the open GL desktop (compiz) 200% smoother.

I just don't understand why it would do that in 16 bits... as soon as I change it back to 24 bits and restart the x server it comes back to normal.

ANy ideas?

flippo
February 11th, 2010, 10:59 PM
try opening a terminal and running:

metacity --replace

This will replace compiz with metacity, if compiz is giving you the troubles this will tell.