PDA

View Full Version : [ubuntu] gnome/compiz: howto prevent "effects" downgrade?



edgue
February 8th, 2010, 02:41 PM
Hello there,

I figured that I very much like the "RingSwitcher" application that
one can select using the Compiz configuration manager (ring switcher
allows to switch to apps on different workspaces; an ability that
i really miss with the default app switcher). Unfortunately the
"Ring switcher" requires the "extra" level for visual effects.

Unfortunately x2 ... some applications seem to "break" the
visual effects level. I just installed eclipse 3.6 M5 (to integrate
Jazz, works fine) ... but as soon as I start that eclipse ...

thump ... visual effects switch to "none" ... and thump x2
the ring switcher gets deactivated and I am back to
ordinary switcher.

Pretty annoying.

Any idea
a) how to prevent this auto-switching?
b) at least: how to restore my settings script-based?
(clicking through the appereance and compiz panels three times
a day becomes pretty annoying)

Talking about such subtle things ... anyone knows how to
prevent this "shaking" of windows when ring switcher is
used? What I mean: you select a window, its maximized ...
but instead of just "going maximized" ... the windows
"shake" a bit before they become useable.

idlehands
March 12th, 2010, 10:02 PM
bump

Frogs Hair
March 13th, 2010, 04:27 AM
Hi,

If you have not done this , go to preferences , select appearance, select visual effects tab, and check the Extra box.

Some of the effects in compiz require the highest graphics setting. If you don't have a
powerful enough card you may not be able to run all compiz features.