PDA

View Full Version : [SOLVED] wireless connects, but no internet



bellt
January 23rd, 2010, 02:33 AM
I'm connecting to my wireless, but I can't connect to the Internet, not even via an IP address. Thanks in advance...

(*) Can not open web pages via IP address.
(*) Can ping internal hardware no problem.
(*) I can connect to the Internet via Ethernet no problem.
(*) I used to be able to connect via wireless on this computer. No settings changed in the interim.
(*) Several other computers currently connected & accessing Internet via the same wireless - no problem.
(*) Based on other posts, I disabled the avahi daemon, but this had no effect.

Outputs of some commands:

bellt@system76-pc:~$ uname -r
2.6.31-17-generic

lspci -v:
02:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
Subsystem: Intel Corporation Device 1201
Flags: bus master, fast devsel, latency 0, IRQ 34
Memory at f4200000 (64-bit, non-prefetchable) [size=8K]
Capabilities: <access denied>
Kernel driver in use: iwlagn
Kernel modules: iwlagn

bellt@system76-pc:~$ cat /etc/resolv.conf
# Generated by NetworkManager
bellt@system76-pc:~$

bellt@system76-pc:~$
bellt@system76-pc:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:90:f5:91:61:af
inet addr:172.16.31.51 Bcast:172.16.31.255 Mask:255.255.255.0
inet6 addr: fe80::290:f5ff:fe91:61af/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1551 errors:0 dropped:0 overruns:0 frame:0
TX packets:1189 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1830508 (1.8 MB) TX bytes:217448 (217.4 KB)
Interrupt:32 Base address:0x4000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:480 (480.0 B) TX bytes:480 (480.0 B)

wlan0 Link encap:Ethernet HWaddr 00:22:fa:58:50:8c
inet addr:10.42.43.1 Bcast:10.42.43.255 Mask:255.255.255.0
inet6 addr: fe80::222:faff:fe58:508c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:576 (576.0 B)

wmaster0 Link encap:UNSPEC HWaddr 00-22-FA-58-50-8C-00-00-00-00-00-00-00-00-00-00
UP RUNNING MTU:0 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

bellt@system76-pc:~$

bellt@system76-pc:~$ ping 10.42.43.1 -c 4
PING 10.42.43.1 (10.42.43.1) 56(84) bytes of data.
64 bytes from 10.42.43.1: icmp_seq=1 ttl=64 time=0.104 ms
64 bytes from 10.42.43.1: icmp_seq=2 ttl=64 time=0.069 ms
64 bytes from 10.42.43.1: icmp_seq=3 ttl=64 time=0.069 ms
64 bytes from 10.42.43.1: icmp_seq=4 ttl=64 time=0.070 ms

--- 10.42.43.1 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 2997ms
rtt min/avg/max/mdev = 0.069/0.078/0.104/0.015 ms
bellt@system76-pc:~$

bellt@system76-pc:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11abgn ESSID:"shooting_star"
Mode:Ad-Hoc Frequency:2.412 GHz Cell: 9E:25:19:03:CB:2F
Tx-Power=15 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

bellt@system76-pc:~$

fibercode
January 23rd, 2010, 02:48 AM
From your post it seems that you have no DNS server specified in your /etc/resolv.conf file.

Do this:

echo "nameserver 8.8.8.8" | sudo tee -a /etc/resolv.conf

That will make one of the open public Google DNS servers the default DNS server for your computer.

Edit: You also state that you cannot open pages by IP address, which means that not having DNS server specified is not the only issue you are having.

Please do the above and then post back a ping to a server on the internet. In your post you pinged the IP address of the wireless NIC:

wlan0 Link encap:Ethernet HWaddr 00:22:fa:58:50:8c
inet addr:10.42.43.1 Bcast:10.42.43.255 Mask:255.255.255.0
.....
bellt@system76-pc:~$ ping 10.42.43.1 -c 4

bellt
January 23rd, 2010, 03:02 AM
From your post it seems that you have no DNS server specified in your /etc/resolv.conf file.

Do this:

echo "nameserver 8.8.8.8" | sudo tee -a /etc/resolv.conf

That will make one of the open public Google DNS servers the default DNS server for your computer.

Please do the above and then post back a ping to a server on the internet.
.....
bellt@system76-pc:~$ ping 10.42.43.1 -c 4

I did as you suggested, but still get
connect: Network is unreachable

when I try ping 4.2.2.2

fibercode
January 23rd, 2010, 03:31 AM
OK then,

Can you post the output of the following command:


route -n

Right after that post the output of the ifconfig command again.

Edit: Can you also post the ifconfig (for Linux/Apple computers) or ipconfig (for Windows) of any other computer on your network. I just want to make sure that your computer is on the same LAN network.

bellt
January 23rd, 2010, 12:21 PM
OK then,

Can you post the output of the following command:


route -nRight after that post the output of the ifconfig command again.

Edit: Can you also post the ifconfig (for Linux/Apple computers) or ipconfig (for Windows) of any other computer on your network. I just want to make sure that your computer is on the same LAN network.


bellt@system76-pc:~$ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.42.43.0 0.0.0.0 255.255.255.0 U 2 0 0 wlan0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 wlan0
bellt@system76-pc:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:90:f5:91:61:af
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:32 Base address:0x6000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:480 (480.0 B) TX bytes:480 (480.0 B)

wlan0 Link encap:Ethernet HWaddr 00:22:fa:58:50:8c
inet addr:10.42.43.1 Bcast:10.42.43.255 Mask:255.255.255.0
inet6 addr: fe80::222:faff:fe58:508c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:576 (576.0 B)

wmaster0 Link encap:UNSPEC HWaddr 00-22-FA-58-50-8C-00-00-00-00-00-00-00-00-00-00
UP RUNNING MTU:0 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

bellt@system76-pc:~$

From my PC (Vista 64):
C:\Users\Tom>ipconfig

Windows IP Configuration


Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::c16b:9f76:c69e:5586%12
IPv4 Address. . . . . . . . . . . : 172.16.31.21
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 172.16.31.1

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : us.dell.com

Tunnel adapter Local Area Connection* 6:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Local Area Connection* 7:

Connection-specific DNS Suffix . :
IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e74:28ea:3e63:53ef:e0ea
Link-local IPv6 Address . . . . . : fe80::28ea:3e63:53ef:e0ea%10
Default Gateway . . . . . . . . . : ::

Tunnel adapter Local Area Connection* 12:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

C:\Users\Tom>

fibercode
January 24th, 2010, 06:45 AM
Your wireless NIC has an IP address of 10.42.43.1.

It is invalid for your network. Your network is 172.16.31.0.

Do you have DHCP enabled for your wireless on your computer?

If you don't, enable DHCP by going to Preferences -> Network Connections -> Wireless , then choose your wireless access point and hit Edit, then on the IPv4 Settings tab select the "Automatic DHCP". Then reboot and you should have internet.

If you already had "Automatic DHCP" enabled, that means that for whatever reason you are not getting a valid IP address assigned from your DHCP server (which probably is your router).

Not to worry, you can add the network settings manually. In the same screen select "Manual" and hit the "Add" button.
Then put the following settings:

IP Address: 172.16.31.101
Netmask: 255.255.255.0
Gateway: 172.16.31.1
DNS Server: 8.8.8.8

Then hit Apply.

This should solve your problem.

bellt
January 24th, 2010, 08:15 PM
Your wireless NIC has an IP address of 10.42.43.1.

It is invalid for your network. Your network is 172.16.31.0.

Do you have DHCP enabled for your wireless on your computer?

If you don't, enable DHCP by going to Preferences -> Network Connections -> Wireless , then choose your wireless access point and hit Edit, then on the IPv4 Settings tab select the "Automatic DHCP". Then reboot and you should have internet.

If you already had "Automatic DHCP" enabled, that means that for whatever reason you are not getting a valid IP address assigned from your DHCP server (which probably is your router).

Not to worry, you can add the network settings manually. In the same screen select "Manual" and hit the "Add" button.
Then put the following settings:

IP Address: 172.16.31.101
Netmask: 255.255.255.0
Gateway: 172.16.31.1
DNS Server: 8.8.8.8

Then hit Apply.

This should solve your problem.


After multiple hours, I fixed the issue. I could edit my wireless connection to make the changes you suggested, but I was unable to select that network to connect to it (it's a known bug - see https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/446394). When I tried to create a connection from scratch, the default settings did not include the "Automatic DHCP". Again, I could change the newly created connections settings, but I could not select the new network connection on subsequent attempts.

I fixed this by installing the latest Network Manager and editing the connection as you suggested.

Thanks for your help - much appreciated.

fibercode
January 24th, 2010, 10:02 PM
You are welcome...

Can you update the thread to "Solved"?

Rao27
March 23rd, 2010, 02:47 PM
Hello,

Thanks for all the postings, my problem was almost the same, but, symptom suddenly changed as soon as made "Automatic DHCP" and rebooted my laptop.

After reboot, wireless is completely disabled. route -n does NOT even show anything ...

Any ideas ?, appreciate help...

Thanks
Rao