PDA

View Full Version : [gnome] another no sound thread...



Nightstalker2
January 22nd, 2010, 08:55 PM
I have no sound in Ubuntu 6.10. I just installed it fresh, and so there is basically nothing I could have done to break it.

Here is my aplay -l:


@ubuntu:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ICH6 [Intel ICH6], device 0: Intel ICH [Intel ICH6]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ICH6 [Intel ICH6], device 4: Intel ICH - IEC958 [Intel ICH6 - IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: CA0106 [CA0106], device 0: ca0106 [CA0106]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: CA0106 [CA0106], device 1: ca0106 [CA0106]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: CA0106 [CA0106], device 2: ca0106 [CA0106]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: CA0106 [CA0106], device 3: ca0106 [CA0106]
Subdevices: 1/1
Subdevice #0: subdevice #0

Here is my alsamixer:


[AlsaMixer v1.0.20 (Press Escape to quit)]──────────────────┐
│ Card: Intel ICH6 │
│ Chip: Analog Devices AD1980 │
│ View: [Playback] Capture All │
│ Item: Master [dB gain=0.00, 0.00] │
│ │
│ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ │
│ │▒▒│ │ │ │ │ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │ │ │ │ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ >
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ Shared │▒▒│ │
│ ├──┤ ├──┤ ├──┤ ┌──┐ ├──┤ ├──┤ ├──┤ │
│ │OO│ │MM│ │OO│ │MM│ │OO│ │OO│ │OO│ │
│ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ │
│ 100<>100 74 81<>81 100<>100 100<>100 100 │
│ < Master >Master M Master S Headphon PCM Surround Surround Center

So it doesn't look like anything is muted. But I don't know what else I should do. Any suggestions?

Nightstalker2
January 24th, 2010, 01:02 AM
bump....

Temüjin
January 24th, 2010, 03:49 AM
It looks like you have 2 sound cards; an onboard chip and a discrete one. Which one are you trying to use?

Nightstalker2
January 25th, 2010, 04:42 PM
Whichever one is the Sound Blaster 24-bit (I don't know if you can tell from the above which one it is). I think it is the non-Intel one

Temüjin
January 25th, 2010, 06:48 PM
Disable your onboard audio in the BIOS if you don't need it. That's the easiest way.

Nightstalker2
January 27th, 2010, 01:16 AM
How do I do that?

VertexPusher
January 27th, 2010, 10:05 AM
Copy these lines into a text editor and save the file as ".asoundrc" in your user home directory:

defaults.pcm.!card CA0106
defaults.ctl.!card CA0106
This will make the Sound Blaster card your default sound card.

Temüjin
January 27th, 2010, 11:57 AM
Copy these lines into a text editor and save the file as ".asoundrc" in your user home directory:

defaults.pcm.!card CA0106
defaults.ctl.!card CA0106
This will make the Sound Blaster card your default sound card.

Thanks for posting the asoundrc config, but I think the user would be better off disabling the onboard audio in the BIOS. Why load a driver for a device you're not using? It only wastes memory and increases the chances of things going wrong.

Nightstalker2: the setting for the onboard audio should be somewhere in your BIOS/System Setup. Try pressing 'Del' or 'F1' when you boot your system.