PDA

View Full Version : [SOLVED] internal microphone doesn't work in cheese and skype



engzks
January 21st, 2010, 05:23 AM
I am using UNR 9.10

Sound recording from build-in mic was fine in skype and cheese after i installed UNR in my Acer Aspire One 110L in early December last year.

But somehow, i just realized that my sound recording was not functioning when i use skype this morning.

(i don't know since when this problem occur as i never use skype and cheese in past few weeks and i did update a few time from synaptic and install ubuntu-boot kernel)

just now i remove ubuntu-boot and reinstall the 2.6.31-17-generic kernel and run

sudo dpkg-reconfigure pulseaudio

but skype and cheese still does not record from build in microphone but only record from external microphone.

One weird thing is Sound recorder do record from both the build-in mic and external mic.

i tried "parec -r test.wav" and "parec -p test.wav" and it also record from both mic.

Anyone know how to configure my netbook so that the internal mic work on skype?

engzks
January 21st, 2010, 05:53 AM
Now i realize that it is not no sound but it is actually the recording volume is very low in skype and cheese but it is alright else where.

if i set the mic boost in alsamixer to maximum and the input volume (in the "Input" tab in "Sound Preferences") to maximum, i manage to record some very very soft sound in cheese.

Anyone know where to set the recording volume?

engzks
January 23rd, 2010, 02:22 AM
sloved

https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/433055

tubunu
June 26th, 2010, 09:20 PM
sloved

https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/433055

Thanks for the link, the sound in Skype works now!

Chiapo
October 9th, 2010, 01:09 AM
Since nobody has added what the above link contains, I thought I'd add it here:

At the end of the discussion, a suggestion is made to invoke the alsamixer from terminal, navigate to the "Mic-boost" & "Capture" areas by using the [TAB] key, use the left|right arrow keys to select individual elements, & the up|down arrow keys to adjust levels.


alsamixer

I followed the instructions in this thread, but failed to follow the link shared above, thus had no sound from my mic until running alsamixer.

Thanks for sharing!