PDA

View Full Version : [ubuntu] Ubuntu 9.1 Video Problems with Sony KDL-40V5100



tizzod
January 13th, 2010, 09:27 PM
I just bought a new TV and I'm trying to use my ubuntu box as a media server. I've included my specs below.

Ubuntu recognizes the TV fine and the resolution is automatically set to 1920x1080 according to the display prefs which is native to the TV. I can see the desktop but it extends beyond the borders of my TV, which makes me think that somehow the resolution isn't set properly. I can't see my top or bottom task bar at all

Furthermore, the image is quite messed up. It's hard to explain, but text doesn't appear properly, nor do any icons etc on the desktop, they're somewhat pixellated.

What's even more confusing is that movies themselves seem to play fine. I've downloaded some 720p mkv's and they play great, so it's just the desktop itself that is messed.

I've installed the NVidia driver manually from their site and it's the latest 173.14.22. Any thoughts are greatly appreciated

Setup
Ubuntu 9.1
AMD Athlon 1800+
Nvidia GeForce FX 5600XT using DVI out
Nvidia Driver 173.14.22 installed from nvidia package (not ubuntu)
Dvi to HDMI Cable
Ubunbu Display Settings:
Resolution: 1920x1080
Refresh Rate: 60hz (TV supports 120 but I couldn't set this)

tizzod
January 14th, 2010, 02:58 PM
Ok to update, the zoom settings on the TV were wrong so that's why it was stretched over the screen. Unfortunately the video quality is still an issue. It almost looks like horizontal lines across the desktop, though not consistently. Does anyone have experience setting up Ubuntu with a TV that might have some insight?