View Full Version : [ubuntu] Network printing HP4240 problem

January 12th, 2010, 10:52 PM
Hi all.
I am new to Ubuntu, around 2 weeks.
Yesterday I installed successfully a network printer, a HP Laserjet 4240, it actually was really easy to do, after printing the test page and it came out with the grayscale graphic I supposed everything was good...
Until today... when I actually tried to print a PDF document. It sends to the printer, says ¨Processing¨ and then the Complete message, but the printer does NOTHING.
I can send how many test pages I want, and they work fine, but nothing comes up from actual documents, neither PDFs or OpenOffice writer.
I have Ubuntu Karmic Koala 9.10
Thanks in advance.

January 12th, 2010, 10:54 PM
Is cups currently running? I have had some issues recently where the cups daemon is not starting on startup. Try opening a terminal and entering sudo /etc/init.d/cups restart

This will restart the cups daemon if it is not running.

January 12th, 2010, 11:44 PM
* Restarting Common Unix Printing System: cupsd [ OK ]

Same result

January 12th, 2010, 11:49 PM
An update...
It is printing from Open Office Writer, last time didnt because a network error.
So. why is not printing PDFs? could be a problem with document viewer?
I am going to try opening the PDFs with another viewer and post a result soon.

January 12th, 2010, 11:57 PM
Can not believe it.
Opened it with Okular, and printed fine.
Wonder if this is a bug???

January 12th, 2010, 11:58 PM
Not sure, but glad things are working for you. Perhaps it was the same network error that affected your other print jobs?

January 13th, 2010, 12:20 AM
I was thinking on that possibility too, but no, I already checked, is just Document Viewer don´t print, and don´t know why

January 13th, 2010, 10:10 AM
Could it be a document viewer problem? I had issues with some .pdf files in document viewer. Adobe Acrobat reader for Linux seems slower but so far is pretty reliable.