PDA

View Full Version : [SOLVED] nvidia-settings twinview configuration does not stick



KhaaL
January 12th, 2010, 09:46 PM
I have my TV connected to my computer through a DVI-HDMI cable, and I have to start nvidia-settings every time i reboot in order to configure twinview to clone the screen to my TV. This is annoying and I wonder how I can make these settings to stick? does the values in xorg.conf still have effect?

techstop
January 12th, 2010, 11:05 PM
Is it only your TV connected, or do you have a monitor as well? Have you tried the "Save to X configuration file" and "Save Configuration" options in nVidia settings?

wojox
January 12th, 2010, 11:11 PM
And you are saving as root:


gksudo nvidia-settings

KhaaL
January 13th, 2010, 09:34 PM
techstop, i have also my monitor connected, sorry forgot to mention that.

Wojox, doh i havent tried that yet! I hope it wont mess upp my xorg.conf though... will post here again with the result :-)

EDIT: Sudo did the trick, thanks!

JDahl
January 20th, 2010, 07:43 PM
I have the exact same problem. I have two monitors setup in
twinview, and everytime I reboot I have to run nvidia-settings
to enable the second monitor.

I also tried running


gksu nvidia-settings

and verified that the timestamp on /etc/X11/xorg.conf was updated,
but the problem remains.

I included my xorg.conf file:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@crested) Sun Feb 1 20:25:37 UTC 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "DELL 2001FP"
HorizSync 31.0 - 80.0
VertRefresh 56.0 - 76.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Quadro NVS 140M"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-1"
Option "metamodes" "CRT: nvidia-auto-select +0+0, DFP-0: NULL, DFP-1: nvidia-auto-select +1600+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection


The xorg.conf mentions one of my monitors DELL 2001FB, but
my second monitor DELL2407WFPHC isn't listed. Isn't that wrong?

HappyFeet
January 20th, 2010, 09:12 PM
Try this:

Do:

sudo rm /etc/X11/xorg.conf
then restart nvidia-settings with:

gksudo nvidia-settings
then make all the changes you need, apply, then save configuration, and it will see you don't have a xorg.conf file. A new window will open. Hit the button labeled show output, and copy the file. Leave nvidia-settings open, and open a new terminal. Do:

sudo touch /etc/X11/xorg.conf && sudo gedit /etc/X11/xorg.conf
then paste what you copied from nvidia-settings. Save and reboot.

ghetolay
March 27th, 2013, 12:30 PM
I know it's an old thread but I had the same problem with ubuntu 12.10 until today.

Problem wasn't nvidia-settings but ~/.config/monitor.xml used by ubuntu which had "<clone>" at "no".
More information here (http://www.sudo-juice.com/dual-monitor-settings-in-ubuntu/).