PDA

View Full Version : [ubuntu] Acer fan control



kermit2435
January 11th, 2010, 11:17 AM
Does anyone have an idiots guide to controlling the fan on an Acer Aspire One, I am a newbie to this linux lark so need a Janet and John guide i.e open a terminal and type "bla bla". I am currently running version 9.10, the previous version 9.04 had the facility for me to open a terminal and type the following "sudo /usr/local/bin/acerfand" this would switch the fan off until the CPU got hot.
I am not familiar with installing packages so really need the Janet and John approach.
Thanks Kev:D

wojox
January 11th, 2010, 11:31 AM
With A110 and UNR v9.10, (late 2009 release), the only thing needed to be changed form the vanilla install is to edit /etc/modprobe.d/acerhdf.conf and add the line: options acerhdf kernelmode=1 then reboot. This controls the fan and is worth swapping to ubuntu just for this, the netbook is then silent apart from the sound made by using the keyboard..

https://help.ubuntu.com/community/AspireOne/Ubuntu9.10

shuttleworthwannabe
January 11th, 2010, 12:14 PM
With A110 and UNR v9.10, (late 2009 release), the only thing needed to be changed form the vanilla install is to edit /etc/modprobe.d/acerhdf.conf and add the line: options acerhdf kernelmode=1 then reboot. This controls the fan and is worth swapping to ubuntu just for this, the netbook is then silent apart from the sound made by using the keyboard..

https://help.ubuntu.com/community/AspireOne/Ubuntu9.10

Any such luck for my lenovo ThinkPad x200--the fan is just unbearable?

kermit2435
January 11th, 2010, 06:41 PM
With A110 and UNR v9.10, (late 2009 release), the only thing needed to be changed form the vanilla install is to edit /etc/modprobe.d/acerhdf.conf and add the line: options acerhdf kernelmode=1 then reboot. This controls the fan and is worth swapping to ubuntu just for this, the netbook is then silent apart from the sound made by using the keyboard..

https://help.ubuntu.com/community/AspireOne/Ubuntu9.10

Thanx, but how do I get to the line to edit ?:popcorn:

shuttleworthwannabe
January 11th, 2010, 06:48 PM
Thanx, but how do I get to the line to edit ?:popcorn:

Run this is terminal

sudo gedit /etc/modprobe.d/acerhdf.conf

kermit2435
January 11th, 2010, 07:03 PM
With A110 and UNR v9.10, (late 2009 release), the only thing needed to be changed form the vanilla install is to edit /etc/modprobe.d/acerhdf.conf and add the line: options acerhdf kernelmode=1 then reboot. This controls the fan and is worth swapping to ubuntu just for this, the netbook is then silent apart from the sound made by using the keyboard..

https://help.ubuntu.com/community/AspireOne/Ubuntu9.10

I keep getting permission denied, how do I switch this bloody thing off, it's driving me mad Gibber Gibber:(

kermit2435
January 11th, 2010, 08:12 PM
Run this is terminal

sudo gedit /etc/modprobe.d/acerhdf.conf


Thank you -Silence is Golden!:P

shuttleworthwannabe
January 11th, 2010, 08:20 PM
you are most welcome!

now can you help me with my Thinkpad X200--the noise is driving me nuts---I feel like I lunatic with all the fan-noise buzzing in my head.

kermit2435
January 11th, 2010, 09:43 PM
you are most welcome!

now can you help me with my Thinkpad X200--the noise is driving me nuts---I feel like I lunatic with all the fan-noise buzzing in my head.

If it's running windows I highly recommend the free program - aa1 fan control, if your running Ubuntu I'm a newbie with capital N, I did a general search on fan control and there were lots of posts, but most were over my head?

wojox
January 12th, 2010, 12:52 PM
you are most welcome!

now can you help me with my Thinkpad X200--the noise is driving me nuts---I feel like I lunatic with all the fan-noise buzzing in my head.

Could try this:

http://www.howtoforge.com/cpu_frequency_scaling_ubuntu

shuttleworthwannabe
January 12th, 2010, 04:53 PM
@kermit: that is for acer only. I have a Lenovo Thnkpad.
@wojox: Thanks, is cpu scaling not a feature now with the new kernels; I checked it out and CPU freq scaling is already working fine.

3ar1
May 31st, 2010, 07:24 PM
Does this still apply to Ubuntu 10.04?
There's no /etc/modprobe.d/acerhdf.conf on my system. How would I install acerhdf? I searched the Ubuntu Software Center without any luck.

alchemistkevin
June 2nd, 2010, 01:48 PM
Does this still apply to Ubuntu 10.04?
There's no /etc/modprobe.d/acerhdf.conf on my system. How would I install acerhdf? I searched the Ubuntu Software Center without any luck.
did you try to edit /etc/modprobe.d/acerhdf.conf and add the line: options acerhdf kernelmode=1 and reboot?

I'm having the same problem on Acer AOA150/acerhdf 0.5.20/BIOS 0.3310

monograph
November 14th, 2010, 11:05 AM
I seem to have the opposite problem with my ACER 5720Z Dual Core Intel. When I installed Ubuntu 10.10 it turned off my fan altogether. So now when i boot up it lasts about 10 mins and then turns off dead. No shutdown just off. I have gone through lots of forums so far about APCI controls and added code to the kernal etc. But I am a linux - newbie and also i cant my system on for long enough to start doing much at all.

In saying this, one time I booted up and the fan ran for the duration of that session. Only did that once and never has done again. Why?