View Full Version : [ubuntu] Linksys connection issue, removal of default in Ubuntu

January 8th, 2010, 04:39 PM
I'm having problems connecting my Eeepc netbook (celeron processor) running 9.1 netbook remix to my Linksys wrt54gl wireless router. The machine can see the wireless network, but won't engage.

I recall some weeks ago a useful post that said words to the effect that there was a default setting in Ubuntu hardy onwards that was getting in the way. A fairly simple command line was given to remove the setting.

I did this on another Eeepc machine (atom processor) which cleared the issue.

I cannot now find this v helpful post.

Anyone out there who can point to either the original post or the relevant default and the command req'd to nullify it?


PS As I see this Linksys thing is a real issue for lots of ubuntu users this would be a great solution to emphasize. It would be real nice if Linksys just solved the problem of course, or the next distro of ubuntu fixed the default...

best wishes


January 8th, 2010, 09:32 PM
Did the suggestion have to do with blacklisting modules, or bypassing IPv6?

January 9th, 2010, 12:09 AM
Yes, bypassing IPv6...


Do you know the commands required?

January 9th, 2010, 04:57 AM
Do you know the commands required?Unfortunately, no... but now you (we?) have a phrase to search for. I need to update the "disable IPV6" link in my signature.

January 9th, 2010, 05:46 PM

I found this in my Ubuntu helpfile:

In terminal...

gksudo gedit/etc/modprobe.d/aliases

find alias net-pf-10 ipv6

change it to read alias net-pf-10 off


I did this, and after a v long delay the machine showed it was connected to my wireless network. But Firefox couldn't find the url (google for test). I'd also turned ipv6 off in firefox.

So, one step forward, two backwards.

There's lots on the forum about changing the firmware on the linksys router... but it looks v daunting.

Thanks again for your help.

January 9th, 2010, 10:12 PM
Here (http://ubuntuforums.org/showpost.php?p=8637126&postcount=2) is another method to look over.

January 10th, 2010, 06:29 PM
Thanks again.

I'm following this thread at the moment... trying to load madwifi drivers onto the Ubuntu machine: