PDA

View Full Version : [ubuntu] 9.10 wireless issues



katie-xx
January 8th, 2010, 01:15 AM
Its a long time since I used Ubuntu but 9.10 tempted me back from the grip of Fedora, albeit via Crunchbang, and I intend to give it a long term trial.
I have spent quite a lengthy period of time trying to persuade the Gnome Network Manager to behave as I want it to but I havent been able to persuade it to connect to a hidden network.
The solution, for me anyhow, was to install WCID, set my wireless connection to use static IP and supply DNS details.

To install WCID simply open a Terminal and type:

sudo apt-get install wcid

(This will also uninstall the Gnome Network manager but if anything goes astray you will be able to reinstall the original network manager with

sudo apt-get install network-manager
)

You will now need to reboot your machine and configure your network properties.
I wanted my default wireless connection to use a static IP address and, much to my surprise, this is possible via the user interface. It just requires a tick in the checkbox and then enter the IP address you require. (Hey dont forget you should have configured your router to dish this out!)
WCID will now fill in default values for NetMask and Gateway for you. However, in my case the Gateway address was incorrect and had to be edited.
You then need to tick the checkbox for Use Static DNS and fill in the details of your preferred DNS Servers.
All that remains is to tick the Use encryption checkbox and select the encryption method.
You should then be in business without changing any of the global settings preferences.
My machine required a reboot to pick up the connection settings and at last the network manager behaves exactly how I want it to.

If you are like me you probably want to clean up after you so it might be an idea to type

sudo apt-get autoclean

Hope this helps anyone still frustrated with the Gnome Network Manager.

In the meantime if anyone has a fix for the starnge behaviour of Gnome Network Manager Id be very interested in seeing it.

Regards
Kate

katie-xx
January 9th, 2010, 12:15 AM
Stupidity rules here Im afraid!
I decided Id have another look at the Gnome Network Manager and reinstalled it.
No surprise it wasnt behaving as expected. However, once I put a Vista box online the Ubuntu connection behaved perfectly.
Turns out my Vista box was set up for Internet Connection Sharing and my Ubuntu box was getting its connection from Vista.
Ive now put that right and have also edited Grub to disable IPV6.
Everything here is now A1 !
Talk about feeling stupid though !!!!

RHTopics
January 9th, 2010, 02:26 AM
Hi Kate,

Welcome to ubuntuforums.

For me, learning from mistakes is part of the Linux experience, especially when it turns out all right in the end.

I just installed Ubuntu 9.10 myself a couple of days ago, replacing Ubuntu 8.04.3. Just discovered "partimage" does not work with ext4 type partitions, so my learning experience continues as well.