PDA

View Full Version : [ubuntu] 9.10 can't connect to windows 7 share



Ravenshoe
January 3rd, 2010, 11:45 PM
Relatively new to linux - please bear with me. :)

My laptop has Ubuntu 9.10. It can connect to shares on my XP and Vista computers without issue, but cannot connect to a share on my Windows 7 system.

I'm using "Connect to Server" and have tried by both Computer name and IP address. When I click connect, it prompts me for User ID, workgroup and password, however when I enter them, the same prompt comes back a few seconds later and is blank. I don't receive any errors, it just won't connect.

My XP and Vista systems can connect to the Windows 7 share, just not the Ubuntu system.

Any ideas?

cariboo
January 4th, 2010, 01:55 AM
Are you using the username and password that you have set in Win 7?

Ravenshoe
January 4th, 2010, 04:07 AM
Are you using the username and password that you have set in Win 7?

Sure am. Would there be a security setting on the Win 7 system that needs to be modified?

PatK100
January 5th, 2010, 04:03 PM
I too am getting this problem - please help

Wollombi
January 10th, 2010, 01:45 AM
It's a known issue for Win7 shares - I believe it is discussed in the Karmic release notes. Supposedly it will be fixed in a future maintenance release.

What that doesn't seem to explain is the problem with XP shares, and I am also experiencing this. Sadly, Karmic has also been the lease stable version of Ubuntu I have used. I'm seriously considering reverting to 9.04, which gave me no issues such as I am experiencing on 9.10. It's either that or Arch, which I don't have time to set up right now.

Ravenshoe
January 14th, 2010, 09:21 PM
[QUOTE=Wollombi;8638856]It's a known issue for Win7 shares - I believe it is discussed in the Karmic release notes. Supposedly it will be fixed in a future maintenance release.

Ahhh.... Thanks - I didn't know that. Karmic seems pretty good so I'll stick with it for now. Hopefully this can be fixed soon.

Bogg
February 12th, 2010, 11:59 AM
I know it's stupid and immature to say "i have this problem too" but... i have this problem too.

I tried enabling different services in my windows 7 but nothing seems to work :|

The guys developing Linux Mint have this problem too (regarding linux mint version 8)

dstein
February 14th, 2010, 10:39 PM
I am having the same problem, but the weird thing for me is that I was not having this problem until I reinstalled Windows 7. Any ideas why reinstalling Windows would initiate this problem? Thanks.

dstein
February 15th, 2010, 04:42 AM
I found the following thread and I was able to resolve my problem. I had to uninstall the Windows Live ID sign-in assistant from the Windows 7 PC. I guess that I had never installed this prior in reinstalling Windows. I hope this helps anyone else with the same problem...

http://ubuntuforums.org/showthread.php?t=1169149

terry0086
February 25th, 2010, 03:59 AM
@dstein
thanks
your solution actually worked for me. The problem was the live sign-in assistant!:)

dr83
March 10th, 2010, 08:30 PM
how do i remove windows live sign in???

dstein
March 11th, 2010, 06:23 AM
Windows Live ID sign-in assistant installs under Windows 7 as part of a Windows update I believe. To remove it, go to the Control Panel, where there should be some icon to click for uninstalling programs (on my computer this icon is labelled "Uninstall a program" or "Programs and features," depending on the view. Find the program and then click uninstall. To prevent this update from showing up again, go back to the Control Panel, and find the Windows Update settings. Right-clicking the Live ID sign-in update and then select "hide," to prevent the update from showing again as an option.

donaldhall
April 22nd, 2010, 03:13 PM
i just did the same thing.

what you need to do is go to synaptic package manager.
install smbnfs and samba
then go into terminal:
mkdir /media/"yoursharename"
then type gedit /etc/fstab
in your fstab folder you should make a new line
#NAME OF DRIVE/SHARE
//"ip address/share" /media/directory you made" iocharset=uft8,_netfs,file_mode=0777,dir_mode=0777

shutdown -r now

once reboot it should show up on your desktop.

if not the you have to edit crontab by typing in root

gedit /etc/crontab

and add this line to the end

@reboot sleep 10;mount -a

hope this works :)

sanjiro
May 15th, 2011, 01:53 PM
@dstein
thanks
your solution worked perfectly for me too. The problem was the live sign-in assistant!:smile:
Meny thanks:popcorn: