View Full Version : [SOLVED] minimal install - wifi configuration

December 30th, 2009, 06:18 PM
It's me again, Margaret… :)

I decided to try to build my own Ubuntu from a minimal install. Since I have a working Karmic (UNR) install on another partition on my machine (an Acer Aspire One 110L), I figured a minimal Karmic image was the best place to start.

The netbook remix installation went by without a hitch: wireless was working out of the box. I was hopeful (though probably as much out of ignorance about the process as any anything) that the minimal install would recognize and configure my wireless hardware correctly. It does recognize the wireless hardware. But it's not working.

$ sudo lshw -C network
description: Wireless interface
product: AR5001 Wireless Network Adapter
vendor: Atheros Communications Inc.
physical id: 0
bus info: pci@0000:03:00.0
logical name: wmaster0
version: 01
serial: 00:22:69:21:09:a3
width: 64 bits
clock: 33MHz
capabilites: pm msi pciexpress msix bus_master cap_list logical ethernet physical wireless
configuration: broadcast=yet driver=ath5k latency=0 multicast=yes wireless=IEEE 802.11bg
resources: irq:18 memory:35200000- 3520ffff

This shows my wireless card is at least being recognized. This is all exactly the same output that I get in the working KarmicUNR install.

Getting wifi going on this machine has been a pain in the keister with every installation I've done, with the notable exception of the Karmic UNR install. I had working wireless on a Hardy install, using madwifi drivers. I couldn't get madwifi to work for me in the brief attempt I made with Crunchbang 9.04. All the troubleshooting threads I've poked through on this forum, and the couple of Ubuntu wiki pages on network troubleshooting… well, I leave them not knowing much more than I did before I started searching. They're either too specific (in the case of the threads here) or too general/outdated (in the case of the wiki pages).

So, if y'all can help me get wireless up and running, I'd appreciate it. I'd love to learn a bit more about how the networking pieces work, and how to troubleshoot when they're not.


Edited to add: I've installed wicd, and I've run wicd-client…

$ wicd-client
Importing pynotify failed, notifications disabled.
Has notifications support False
Connecting to daemon…
Done loading.

And that's it. No GUI, but that may be because there's something I've yet to install. I don't have a task bar yet in Openbox, so I don't have any graphical indication for what it's doing.

December 30th, 2009, 07:48 PM
This works... sort of. The connection seems to drop out after a little while.


$ sudo iwconfig wlan0 essid home
[sudo] password for jeff:
jeff@Karma:~$ sudo dhclient wlan0
Internet Systems Consortium DHCP Client V3.1.2
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/wlan0/00:22:69:21:09:a3
Sending on LPF/wlan0/00:22:69:21:09:a3
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to port 67 interval 4
DHCPREQUEST of on wlan0 to port 67
DHCPACK of from
bound to -- renewal in 885284262 seconds.

December 31st, 2009, 01:48 AM
Ok, I think I've got it solved. I added a tint2 panel, so I can actually use the applet. It finds the network, gives me the option to connect automatically. Rebooted, and it connected. So, unless I continue getting weird disconnect behavior, I'm going to call it good.

I guess I should thank a forum sponsor for giving me a place to verbally process, or something. :rolleyes: