PDA

View Full Version : [ubuntu] video converting!!- Ipod classic 120gb



brunett007
December 30th, 2009, 12:33 PM
Hello

I'm new in this site, and this means I'm new in ubuntu too. I know a lot about Ubuntu but it's some thinks i need help with. One of those is with my ipod. I'm using gtkpod, and it works very nice, but I can't put any video there. I've tried those programs but no one of them worked:
yamipod
amarok2
banshee
avidemux

Then i tried Winff and it works well but when I try to convert the video, it comes a window nd say's : Unknown encoder 'libx264'

:confused:I don't know what this is so.. cn please someone help me????
Need help!!

Bonster
December 30th, 2009, 01:25 PM
make sure u get the gtkpod with aac support, think is called gtkpod-aac in synaptic.

in karmic u have to compile the ffmpeg to get libx264, theres a tut on this forum on it.

FakeOutdoorsman
December 30th, 2009, 08:04 PM
Then i tried Winff and it works well but when I try to convert the video, it comes a window nd say's : Unknown encoder 'libx264'

This is one of the most repeated question that I see on these forums. Fortunately it is easy to fix. As Bonster mentioned you can compile FFmpeg, but you don't have to:

HOWTO: Easily enable MP3, MPEG4, AAC, and other restricted encoding in FFmpeg (http://ubuntuforums.org/showthread.php?t=1117283)

What version of Ubuntu are you using?

LuisGMarine
December 30th, 2009, 09:16 PM
Well I know that banshee 1.5 has video support because I'm staring at it right now.

Best thing is to download Handbrake (http://handbrake.fr/) and use this to convert your videos to the ipod format. Ipod format is nothing more than .mp4 with a certain size. Handbrake has a built in profile to do all this.

Second is give banshee 1.5 another go. 1.5 has video support.

http://banshee-project.org/download/

brunett007
December 31st, 2009, 12:20 AM
What version of Ubuntu are you using?

Hi.. I'm using the Ubuntu 9.10 ;)