PDA

View Full Version : [ubuntu] audio problem PLEASE HELP!!!



vendetta314
December 28th, 2009, 10:29 AM
i just installed ubuntu 9.10 and i love it! but i dont get any sound at all! i installed the latest realtek ac97 driver for linux and it installed (i think) and i restarted my pc and still no sound. i am kinda new at ubuntu 9.10 and frustrated. please help cuz i wanna listen to music and watch videos.

AshNZ
December 28th, 2009, 12:36 PM
I'm no expert but I had same problem. You might get something by following the thread I posted: http://ubuntuforums.org/showthread.php?t=1364521

Have you tried this? http://ubuntuforums.org/showthread.php?t=205449

vendetta314
December 29th, 2009, 09:55 PM
it still didnt work. i ttried alsamixer and i amped everything up and still no sound.
darrell@darrell-desktop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ICH5 [Intel ICH5], device 0: Intel ICH [Intel ICH5]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ICH5 [Intel ICH5], device 4: Intel ICH - IEC958 [Intel ICH5 - IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0
darrell@darrell-desktop:~$

this is my sound card i think.

VertexPusher
December 29th, 2009, 10:12 PM
Run this command to test your sound card:

speaker-test -D plughw:ICH5 -c 2
If you see an error message, copy and paste it here.

If there is no error but no sound either, run

amixer
and copy its entire output here.

vendetta314
December 29th, 2009, 10:51 PM
i typed in the first command you gave me and i get this:

darrell@darrell-desktop:~$ speaker-test -D plughw:ICH5 -c 2

speaker-test 1.0.20

Playback device is plughw:ICH5
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 8 to 16384
Period size range from 8 to 16384
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
0 - Front Left
1 - Front Right
Time per period = 5.632676
0 - Front Left
1 - Front Right
Time per period = 5.972668
0 - Front Left
1 - Front Right
Time per period = 5.972712
0 - Front Left
1 - Front Right
Time per period = 5.972672
0 - Front Left
1 - Front Right
Time per period = 5.972704
0 - Front Left
1 - Front Right
Time per period = 5.972705
0 - Front Left
1 - Front Right

.....continually. then i typed in the other command and i get this.....

darrell@darrell-desktop:~$ amixer
Simple mixer control 'Master',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] [0.00dB] [on]
Front Right: Playback 31 [100%] [0.00dB] [on]
Simple mixer control 'Master Mono',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 31
Mono: Playback 0 [0%] [-46.50dB] [off]
Simple mixer control 'Master Surround',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] [0.00dB] [on]
Front Right: Playback 31 [100%] [0.00dB] [on]
Simple mixer control 'Headphone Jack Sense',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'PCM',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] [12.00dB] [on]
Front Right: Playback 31 [100%] [12.00dB] [on]
Simple mixer control 'Surround',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 31 [100%] [0.00dB] [on]
Front Right: Playback 31 [100%] [0.00dB] [on]
Simple mixer control 'Surround Jack Mode',0
Capabilities: enum
Items: 'Shared' 'Independent'
Item0: 'Shared'
Simple mixer control 'Center',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 31
Mono: Playback 31 [100%] [0.00dB] [on]
Simple mixer control 'LFE',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 31
Mono: Playback 31 [100%] [0.00dB] [on]
Simple mixer control 'Line',0
Capabilities: pvolume pswitch cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Front Left: Playback 31 [100%] [12.00dB] [off] Capture [off]
Front Right: Playback 31 [100%] [12.00dB] [off] Capture [off]
Simple mixer control 'Line Jack Sense',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control 'CD',0
Capabilities: pvolume pswitch cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Front Left: Playback 25 [81%] [3.00dB] [on] Capture [off]
Front Right: Playback 25 [81%] [3.00dB] [on] Capture [off]
Simple mixer control 'Mic',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Mono
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono: Playback 0 [0%] [-34.50dB] [off]
Front Left: Capture [on]
Front Right: Capture [on]
Simple mixer control 'Mic Boost (+20dB)',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control 'Mic Select',0
Capabilities: enum
Items: 'Mic1' 'Mic2'
Item0: 'Mic1'
Simple mixer control 'Video',0
Capabilities: cswitch cswitch-exclusive
Capture exclusive group: 0
Capture channels: Front Left - Front Right
Front Left: Capture [off]
Front Right: Capture [off]
Simple mixer control 'Phone',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Mono
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono: Playback 0 [0%] [-34.50dB] [off]
Front Left: Capture [off]
Front Right: Capture [off]
Simple mixer control 'IEC958',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'IEC958 Playback AC97-SPSA',0
Capabilities: volume volume-joined
Playback channels: Mono
Capture channels: Mono
Limits: 0 - 3
Mono: 0 [0%]
Simple mixer control 'IEC958 Playback Source',0
Capabilities: enum
Items: 'AC-Link' 'A/D Converter'
Item0: 'AC-Link'
Simple mixer control 'Aux',0
Capabilities: pvolume pswitch cswitch cswitch-exclusive
Capture exclusive group: 0
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: Playback 0 - 31
Front Left: Playback 31 [100%] [12.00dB] [off] Capture [off]
Front Right: Playback 31 [100%] [12.00dB] [off] Capture [off]
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 15
Front Left: Capture 0 [0%] [0.00dB] [on]
Front Right: Capture 0 [0%] [0.00dB] [on]
Simple mixer control 'Mix',0
Capabilities: cswitch cswitch-exclusive
Capture exclusive group: 0
Capture channels: Front Left - Front Right
Front Left: Capture [off]
Front Right: Capture [off]
Simple mixer control 'Mix Mono',0
Capabilities: cswitch cswitch-exclusive
Capture exclusive group: 0
Capture channels: Front Left - Front Right
Front Left: Capture [off]
Front Right: Capture [off]
Simple mixer control 'Channel Mode',0
Capabilities: enum
Items: '2ch' '4ch' '6ch'
Item0: '2ch'
Simple mixer control 'Downmix',0
Capabilities: enum
Items: 'Off' '6 -> 4' '6 -> 2'
Item0: 'Off'
Simple mixer control 'Exchange Front/Surround',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control 'External Amplifier',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'High Pass Filter Enable',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'Spread Front to Surround and Center/LFE',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control 'V_REFOUT Enable',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
darrell@darrell-desktop:~$

i dont know what any of this means i am new to all this.

vendetta314
December 29th, 2009, 10:52 PM
i get no sound with the test.

VertexPusher
December 29th, 2009, 11:14 PM
The "Master Mono" volume slider is set to 0% and muted. Does it make a difference if you unmute it and turn it up?

vendetta314
December 29th, 2009, 11:37 PM
do i use alsamixer? or something else? sorry im new to all this.

VertexPusher
December 29th, 2009, 11:46 PM
Yes, run alsamixer in a separate terminal window while the test program is running. Unmute all the sliders and turn them all the way up until you hear something.

vendetta314
December 29th, 2009, 11:57 PM
yea i did all of that even messed with 2 different speakers. still no sound. i messed with the alsamixer and sound preferences and all of that. headphones. speakers. nothing. and all of the audio jacks in back of pc.

garvinrick4
December 30th, 2009, 12:00 AM
Part A: Common instructions (Hardy, Intrepid, Jaunty & Karmic)
All users must must follow the steps in this section to guarantee a fully working PulseAudio configuration.

1. Backup (and then delete) your previous configuration files:
Code:
$ mkdir ~/pulse-backup && cp -r ~/.pulse ~/.asound* /etc/asound.conf /etc/pulse -t ~/pulse-backup/ $ rm -r ~/.pulse ~/.asound* $ sudo rm /etc/asound.conf Warning: As always, use caution when removing files on your system. Any typos can potentially cause data loss.
Note: Don't worry if some of these files did not exist on your system.


2. Ensure you have the necessary PulseAudio libraries and configuration utilities installed:
Code:
$ sudo apt-get install libasound2-plugins padevchooser libsdl1.2debian-pulseaudio 3 (https://bugs.launchpad.net/bugs/192888). Ensure the evil "libflashsupport" library is not installed:
Code:
$ sudo apt-get remove --purge libflashsupport flashplugin-nonfree-extrasound Note: the libflashsupport library was (and to a certain extent, still is) the most common cause of Firefox instability since the Hardy release, because many users have been misled into thinking they must install it to ensure Flash & PulseAudio can work correctly. If you notice any postings that recommend this library to be installed, please reply to the post and point them to this thread, or the bug report linked. The more people that are aware of this issue the better. Thanks!

4. (Karmic users - please skip this step, it's not necessary). Open System/Preferences/Sound. In the Devices section, ensure that all "Sound playback" options are set to Autodetect. Set the "Sound capture" item to "ALSA", or the appropriate hardware definition. Close the application when you're finished.
Note: Choosing PulseAudio for sound capture may result in crashes, so you are advised to choose the "direct" ALSA device instead.

5. Open the PulseAudio Volume Control application ("pavucontrol", or you can launch "Applications/Sound & Video/PulseAudio Device Chooser" and select Volume Control from this applet's menu). In the Output Devices section you will see a listing of the playback devices available on your system. Right-click on the entry that you desire to be made the default playback device on your system and enable the "Default" checkmark. Similarly, navigate to Input Devices, then right-click on the device you wish to set as your default input device (microphone), and ensure the "Default" setting is checked. Close the application when you're finished.

Note: If you are greeted with the error "Connection failed: Connection refused", manually launch PulseAudio before opening the PulseAudio Volume Control application:
Code:
$ pulseaudio & pavucontrol 6. Ensure that your sound card's PCM mixer is not muted or set to 0% volume (this appears to be a common bug in Intrepid and Jaunty):
Code:
$ alsamixer -Dhw Note: When the PulseAudio ALSA plugins are active, you must explicitly specify your hardware device in alsamixer (marked in blue above), otherwise it will open the PulseAudio mixer.

7. Continue to Part B if you are running Hardy Heron (8.04), or Part C if you are running Intrepid Ibex (8.10). If you are running Karmic Koala (9.10) or Jaunty Jackalope (9.04), you're finished - log out and back in for changes to take effect!

VertexPusher
December 30th, 2009, 12:15 AM
When the PulseAudio ALSA plugins are active, you must explicitly specify your hardware device in alsamixer (marked in blue above), otherwise it will open the PulseAudio mixer.
Thanks. I guess that explains why alsamixer doesn't work here.

vendetta314
December 30th, 2009, 12:28 AM
i did all of that just now. still no audio! pulse audio is on and everything. my volume control says mono. how can i get stereo? that might be the problem ya think? the volume meter on pulse audio the bars are movie like i am getting audio im just not hearing it.

VertexPusher
December 30th, 2009, 01:30 AM
Your sound card is working, otherwise there would have been an error message returned by speaker-test. But your mixer settings are wrong. This can only be fixed in alsamixer because that's where the hardware volume levels can be set.

According to garvinrick4's post, you need to launch alsamixer like this:

alsamixer -D hw:0
I didn't know that because I don't use PulseAudio at all, i.e. I don't need the additional "-D hw:0" parameter.

vendetta314
December 30th, 2009, 03:21 AM
i did that. i raised all levels all the way up and un muted everything. still no sound. i have uninstalled ubuntu 9.10 like 5 times and never any sound. it could be the speakers but they work just fine on windows vista on another computer but when plugged in mine under ubuntu 9.10 it wont. i even installed windows 7 and it worked. installed ubuntu 9.10 and it doesnt so it has to be ubuntu or something. idk. its frustrating.

garvinrick4
December 30th, 2009, 04:41 AM
Check your kernal and make sure the alsa backports modules for that kernal are installed
in Synaptic. I have heard in the Forums where in 9.10 Karmic 2.6.31-16-generic that installing
them might be a fix, a lot of folks claimed it was any way, what can hurt to give it a look and install.