PDA

View Full Version : [ubuntu] Screen Freezes after NVIDIA 9643 Install, Geforce2 integrated gpu



Hieronymus Josch
December 8th, 2009, 12:59 AM
[Solved] I ended up buying a GeForce 6200 card and am staring at a big beautiful 1920x1080 screen with full desktop effects. Decided it wasn't worth all the trouble to get an old, slow card with no memory to work with a legacy driver. Thanks to all who helped!

AMD Athlon x86; geforce2 integrated GPU; Ubuntu 9.1 i386

I have posted this same thread at nvnews and have gotten no help

I have had to install fresh copies (http://www.nvnews.net/vbulletin/showthread.php?t=142335#) of Ubuntu 3 times now to get back to functional GUI. After installing nv 96.43.13 (which is the recommended driver in both Ubuntu's hardware (http://www.nvnews.net/vbulletin/showthread.php?t=142335#) driver console and Envy) and restarting, I am greeted with the following errors:



[EE]NVIDIA(0) Unable to use default mode "nvidia-auto-select"
[EE}Screen(s) found, but none have a usable configuration
The first two times I've installed the OS and the driver package I opted to allow nvidia to set up a new configuration. Both times proved disasterous. Upon reboot, the screen would freeze at the ubuntu loading screen and become unresponsive. After which, setting the driver in the xorg.conf file to "nv" allowed ubuntu to boot up fully but my lcd read "input not supported." Setting the driver to "vesa" resulted in an unresponsive black screen during the boot up process.

I have saved the existing conf file that is allowing me to use the GUI now as xorg.conf.backup2 just in case.

I have found a couple of threads here that suggest it may be an issue w/ CPU frequency scaling and that adding the code "exit 0" to /etc/init.d/powernowd resolves the problem. Well, no such file exists on my computer (http://www.nvnews.net/vbulletin/showthread.php?t=142335#). I also read that adding the option "UseDisplayDevice" "DFP" to the device section of the conf file can solve the problem. Neither did for me.

I did notice that after nvidia tries to build a working configuration, my card information never registers in the conf file like it does in others I've seen. The name of my card, it's busid and such never comes up. Is there a way that I can manually build the correct information into the conf file?

Attached are the current logs. Remember, I'm running in low graphics mode and have yet to configure my device to the new driver; I am concerned that when I do my GUI will be kaput. Any help would be greatly appreciated!

Josch

I ran nvidia-xconfig and rebooted. The screen froze at the ubuntu loading screen, as expected. Here is how the xorg.conf file looks:



# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Thu Jun 25 18:57:07 PDT 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
As you can see, the geforce2 integrated gpu is not recognized. What gives?

In reviewing the x server log, my graphics (http://www.nvnews.net/vbulletin/showthread.php?t=142335#) card and monitor are initially recognised then the error



Insufficient memory bandwidth for MetaMode
"nvidia-auto-select" discarding
occurs several times before auto-select is removed completely. If my card is being read initially at PCI:1:0:0 and my monitor recognised, though incorrectly as a CRT, why isn't any of that being transferred to xorg.conf? I tried searching for the above error and got no results.

RedSingularity
December 8th, 2009, 02:25 AM
Try.............. sudo nvidia-xconfig

Hieronymus Josch
December 8th, 2009, 04:59 AM
Try.............. sudo nvidia-xconfig

I'll give it a shot and report back. Thanks.

Hieronymus Josch
December 8th, 2009, 06:33 AM
Well, Red, you may have perhaps gotten me a bit closer. I entererd:


sudo nvidia-xconfig

Then rebooted. The NVIDIA screen didn't pop up like it did before and strangely, I was asked to log in, which I've never had to do before as I've disabled login at startup. There was a lot of artifacting but I was able to login and it loaded KDE with TONS of artifacts. I tried navigating to a terminal so that I could try disabling the frame buffering but it froze up and became unresponsive before I could. I rebooted and this time it had major artifacts at the Ubuntu loading screen and froze up, never launching KDE.

So, I rebooted to recovery console, opened the xorg.conf and changed the driver to "nv" and rebooted. Same as before, ubuntu will load, I can hear the drum beat but my monitor displays "input not supported."

I hit Ctrl+Alt+F1 and opened the xorg.conf again, this time changing the driver to "vesa" and rebooted. Just as before, I booted to a blank unresponsive screen.

Back in recovery console I entered:

sudo dpkg-reconfigure xserver-xorg

and rebooted. Same results.

There's got to be a way to get this thing to at least boot to low graphics mode! This is crazy. Is there a way to uninstall the nvidia 9643 driver completely from the root terminal in the recovery console?

RedSingularity
December 8th, 2009, 06:41 AM
Yeah you can uninstall the whole driver from a command line. What version diver you running? 180, 185, 190? Do you remember?

Hieronymus Josch
December 8th, 2009, 06:46 AM
Yeah you can uninstall the whole driver from a command line. What version diver you running? 180, 185, 190? Do you remember?

version 96.43

RedSingularity
December 8th, 2009, 07:16 AM
sudo apt-get autoremove --purge nvidia-glx-96

Hieronymus Josch
December 9th, 2009, 04:09 AM
Uninstalling nvidia does not fix the problem. X server keeps logging the error "Insufficient memory bandwidth for MetaMode" and "nvidia-auto-select" shuts down. I've attached the log.

Several people have found success by using a patched 87.76 driver but the only write up I've found is for someone with a different video card running feisty.

RedSingularity
December 9th, 2009, 04:21 AM
In the device part of xorg.conf change "nvidia" to "nv" like this...............

Section "Device"
Identifier "Device0"
Driver "nv"
VendorName "NVIDIA Corporation"
EndSection

Then reboot.

Hieronymus Josch
December 9th, 2009, 05:33 AM
Unfortunately, I've been here before. With the driver set to "nv," after restart, ubuntu loads and presumably to KDE but my monitor reads "input not supported." I've attached the resulting xorg log if you care to look.

RedSingularity
December 9th, 2009, 06:29 PM
Well we can use that for now. The graphical interface will be easier to use while you have this problem. Download the nvidia drivers from the site and save them to your desktop. Post back when you have them saved.

Hieronymus Josch
December 9th, 2009, 08:38 PM
Well we can use that for now. The graphical interface will be easier to use while you have this problem. Download the nvidia drivers from the site and save them to your desktop. Post back when you have them saved.

You see, I don't have a graphical interface with the driver set to "nv." There is no output to my monitor. I have a graphical interface now as a result of the xorg.conf file that was created when I opted to start ubuntu in "low graphics mode for just one session" after installing the 96.43 drivers. Those drivers were already installed via Envy. I have downloaded those drivers from the nvidia website to my desktop. But bear in mind, nvidia 96.43 is already installed. If I uninstall them, I run a pretty high risk of losing my GUI but I'm willing to try anything. All of the times I've been through this I downloaded the drivers either through synaptic or Envy.

Hieronymus Josch
December 9th, 2009, 08:53 PM
Nvidia does not list the geforce2 integrated gpu as being supported on their website. As a matter of fact, it doesn't even list it as a model in the driver search. The closest is the Geforce 200 series, which is a different card altogether. Wonder if this card simply isn't compatible.

Hieronymus Josch
December 9th, 2009, 09:47 PM
I take that back, the geforce2 integrated gpu is in the long list of cards supported by the 96.43 legacy driver but it definitely isn't in their driver search tool.

RedSingularity
December 9th, 2009, 10:13 PM
Yes it is an old card......but i am sure they still support it.

Try running this,

system-config-display --reconfig

If that doesnt work use a graphical display to run

sudo nvidia-settings in a terminal.

Hieronymus Josch
December 9th, 2009, 10:18 PM
Yes it is an old card......but i am sure they still support it.

Try running this,

system-config-display --reconfig

If that doesnt work use a graphical display to run

sudo nvidia-settings in a terminal.

I'm sorry, still a bit of a noob. When you say "use a graphical display" you mean like KDE or any GUI for that matter? So the first code should be run from a real terminal, i.e. Ctrl+Alt+F1?

Hieronymus Josch
December 9th, 2009, 10:28 PM
system-config-display --reconfig
command not found


sudo nvidia-settings

Opened the nvidia setting that are accessible through my menu bar. The only options I have are:


Enable ToolTips
Display Status Bar
Slider Text Entries
Include X Display Names in the Config File
Show "Really Quit?" Dialog

RedSingularity
December 9th, 2009, 10:29 PM
You can do both commands in a graphical setup. If that is KDE in your case then use that.

RedSingularity
December 9th, 2009, 10:30 PM
Here try this command to reconfigure........

sudo -dpkg-reconfigure xserver-xorg