PDA

View Full Version : [ubuntu] nvidia compiz problem



echotone
December 6th, 2009, 09:51 AM
I can enable compiz just fine and the nvidia 9500gt was plug and play for me. the cube works great and is really smooth but when i restart my computer the cube locks up my computer. i noticed if i turn all visual effects off and then re-enable them then open compiz manager and re-enable cube it works fine. Is there any way to get this problem fixed?

And i still cant save my xconfig file in the nvidia X server settings so i need to enable the second monitor after a re-boot also. Any clues?

RedSingularity
December 8th, 2009, 02:32 AM
Make a xorg file for nvidia by running this command.....

sudo nvidia-xconfig

If it still doesnt work post the output of your /etc/X11/xorg.conf file.

echotone
December 8th, 2009, 03:34 AM
Here is my xconfig file # nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Fri Aug 14 17:54:58 PDT 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection


But now i have a new problem. For some reason. when i woke up this morning, my computer was recognizing the second monitor but the task bar was only on one. and now i have 2 cubes. one for each monitor. i backed up my files that i wanted and went to re-iinstall the os but i cant get my xpc to boot from a usb or the 9.10 disk. The bios screen flashes too fast for me to read which key i need to press in order for it to open my boot order options.

RedSingularity
December 8th, 2009, 06:36 AM
Do the following to get a longer timeout for selection......

sudo gedit /boot/grub/menu.lst

Change the part that says timeout to something higher like 10 seconds.