PDA

View Full Version : [ubuntu] Is my video card not very good with OpenGL or something?



MetroidJunkie2008
December 5th, 2009, 08:46 PM
With the exception of Sauerbraten, it seems like every Linux native 3D game has framerate problems, from OpenArena to DarkPlaces Quake. Changing the graphical settings affects how much it lags so I'm sure it's the video card having trouble. I have a GeForce 8800GT 512MB and I have the latest Nvidia driver, desktop effects are also completely disabled. What could be causing my video card to become so crippled? I know it can do more than this, I managed to practically max out games like Bioshock and Modern Warfare when I had Windows.

Edit: Before I forget, I have Ubuntu version 9.10

Ringi
December 5th, 2009, 09:37 PM
Did you check the frame rate

glxgears

MetroidJunkie2008
December 5th, 2009, 09:52 PM
That test, of 10 entries, yielded an average of 9666.3 every 5 seconds or 1933.26 a second.

JBAlaska
December 6th, 2009, 12:43 AM
This is what I get with my integrated GeForce 8200:

10390 frames in 5.0 seconds
11175 frames in 5.0 seconds
10974 frames in 5.0 seconds
11097 frames in 5.0 seconds
11081 frames in 5.0 seconds
11171 frames in 5.0 seconds
11138 frames in 5.0 seconds
11144 frames in 5.0 seconds
11084 frames in 5.0 seconds

Just so you have something to compare.

MetroidJunkie2008
December 6th, 2009, 04:15 AM
Looks like my 8800GT is performing worse than your 8200.

Update: Ironically, I just downloaded the Bioshock demo to see how well it would work on Wine, no framerate problems, even at maxed out settings. Yet, most Linux native 3D games that should use far less graphical power give me more problems.

Bioshock Pic (http://i48.tinypic.com/1zptx6q.png)

MetroidJunkie2008
December 7th, 2009, 04:32 AM
Anyone got any ideas? It's weird that Bioshock gives me better performance than what is essentially Quake 3.

Temüjin
December 7th, 2009, 04:47 AM
WHat version of nvidia driver are you using? (Oh, and please use thumbnails).

MetroidJunkie2008
December 7th, 2009, 04:58 AM
As I said, I 'm using the newest one, version 185. It was also recommended.

Temüjin
December 7th, 2009, 04:59 AM
The newest driver is 195.something (from nvidia's site).

MetroidJunkie2008
December 7th, 2009, 05:12 AM
I updated to the new 195.22 and I think it helped. Quake Dark World still lags if I turn shadows on and Quake 3 has some kind of sound lag but it seems better than before.