PDA

View Full Version : [ubuntu] Can't wirelessly connect to my network (but can for others)



Unislash
November 23rd, 2009, 11:49 PM
Hey all,

I'm having a peculiar problem here... I can connect to every network around me but my own. Using Windows, i can connect fine. I have tried the default network manager as well as wcid and both fail to connect.

NM-Applet: It sees my network, i hit connect, it gives me two fields: security type and password. For security type i have one choice: wpa and wpa2 personal. For password, i put in the (correct) password. No typos. It sits there for a bit, tries to connect, then brings up the same screen. Repeat.

Note that i can create a profile for using a different security protocol, but when i hit connect it automatically makes a new profile and uses wpa 1/2


Wcid: It sees my network, i hit connect, it brings up a nice detailed profile manager. I choose WPA 1/2 personal passphrase, type in the key, and it goes about Obtaining IP address... and fails. Same with WPA 1/2 preshared key. The error i get is "Connection failed: unable to get IP address" however, this is apparently a general error.


I've searched around and found some leads here and there. The best looking one is that my network takes the hex version of the password and ubuntu gives it some other version (or visa versa). I tried a fix for it, it didn't work, so i'm back at square one.

Help would be appreciated, as always :)

Cheers,
Unislash