PDA

View Full Version : [SOLVED] DNS Problems with 3G dongle PPP connection



BigglesZX
November 22nd, 2009, 12:04 PM
Hi all,

I've had a search around attempting to find a solution to this problem, but I'm hindered slightly by problems of definition, so I haven't as yet found a fix!

I've got a Dell Mini 9 running UNR 9.10, all up-to-date. I'm using a Huawei E160 HSDPA USB dongle in an attempt to get a mobile Internet connection going. I recently had to re-install UNR due to my irretrievably messing up some packages, and in my previous install the dongle worked fine. Since reinstalling however I have what I believe to be a DNS problem. When the PPP connection is active, attempting to access any URL in Firefox results in an instant "server not found" error - when normally there would be a delay of a few seconds while the request was sent.

Now, when I don't have any credit on my account (with O2 UK PAYG) I would only normally be able to access their "top-up" page, but even that URL is returning a "server not found" immediately. The speed of the error is such that I can only assume it is a DNS problem, perhaps that Ubuntu is trying to resolve DNS on one of the other (disabled) network interfaces (I disabled them all before dialling PPP in order to test it properly). Even with no credit on my account, I should still be able to see DNS lookups being run by the browser, and should definitely still be able to access the "top-up" page (at a slow speed, mind!:)). Running "nslookup" on a host from the Terminal just times out after a few seconds.

I have read about problems with automatic overriding of DNS settings with PPP connections, though I'm not sure they apply in this case. With wifi enabled and PPP offline, my resolv.conf is as follows:


# Generated by NetworkManager
domain domain_not_set.invalid
search domain_not_set.invalid
nameserver 172.16.0.2
nameserver 212.139.132.43
nameserver 212.139.132.44The first IP is my router (correct) and the second and third IPs appear to belong to my ISP (correct), though I'm not sure how Ubuntu got hold of them as they aren't distributed in my DHCP!

When wifi/ethernet are disabled and PPP is connected, resolv.conf is blank (except for the "Generated by NetworkManager" comment). In the settings for the PPP connection, all IP-related settings are set to automatic, however! So perhaps these aren't getting picked up as they should.

I'm not in the biggest of hurries to get this fixed as I don't need to use the Mini 9 out and about for a while, I'm just irked that it worked fine on my first installation! :) But any advice as to how I might go about solving this would be hugely appreciated nonetheless. And if there's any other diagnostic info I should provide, please let me know.

Thanks for reading,

Biggs

EDIT: Further to reading this thread (http://ubuntuforums.org/showthread.php?t=1332302) I can provide the following additional info:

- unable to ping either www.google.com (http://www.google.com) or 74.125.79.99
- output of ip route list is as follows:

10.64.64.64 dev ppp0 proto kernel scope link src 10.52.59.241
169.254.0.0/16 dev ppp0 scope link metric 1000
default via 10.64.64.64 dev ppp0 proto staticHope that helps! :)

EDIT: Solved, see below. I don't seem to be able to change the prefix on the post, sorry!

BigglesZX
November 23rd, 2009, 09:27 AM
Anyone got any ideas about this? Pleeease? :)

Thanks,

Biggs

BigglesZX
November 24th, 2009, 01:31 PM
I've now solved this issue by manually specifying the O2 DNS server in the properties for this PPP connection.

For anyone else looking to do the same, the O2 DNS server is (at time of writing) 193.113.200.201.

In the properties for the Mobile Broadband connection, you need to go to the IPv4 Settings tab, select "Automatic (PPP) addresses only" in the Method dropdown, then in the DNS servers box enter 193.113.200.201.Then disconnect and reconnect your PPP connection and it should work OK.

Hope that helps someone else with this problem!

Biggs

dBz
June 9th, 2010, 02:02 PM
And if you'd rather a solution that doesn't involve hardcoding the DNS server addresses, leave the the tab set at "Automatic(PPP)", and instead, add the following line to

/etc/ppp/options:

ipcp-max-failure 30

Meizirkki
August 29th, 2010, 10:46 AM
I've now solved this issue by manually specifying the O2 DNS server in the properties for this PPP connection.

For anyone else looking to do the same, the O2 DNS server is (at time of writing) 193.113.200.201.

In the properties for the Mobile Broadband connection, you need to go to the IPv4 Settings tab, select "Automatic (PPP) addresses only" in the Method dropdown, then in the DNS servers box enter 193.113.200.201.Then disconnect and reconnect your PPP connection and it should work OK.

Hope that helps someone else with this problem!

Biggs

There is no such Tab in the settings :( I'm running Kubuntu 10.10.


And if you'd rather a solution that doesn't involve hardcoding the DNS server addresses, leave the the tab set at "Automatic(PPP)", and instead, add the following line to

/etc/ppp/options:

ipcp-max-failure 30

This didn't work either.

Anything else I could try ?