PDA

View Full Version : Gma500



jbernardo
November 18th, 2009, 10:26 PM
Anyone's been able to install the GMA500 drivers? I always get a error when dkms is building the psb-kernel-source module, be it with 4.41.2 or 4.41.6 (from Lucazade's ppa).
I removed the package to try to start X with the vesa driver (which now fails complaining of a non-existing /dev/fb0), but the error was "error: implicit declaration of function 'phys_to_gart'". From what I googled it has been deprecated; unfortunately I don't have the knowledge to fix this, and was hoping anyone been able to patch it already.

Thanks!

lucazade
November 20th, 2009, 09:58 PM
new release, same story.. :-?
I haven't tried lucid on my netbook, so no idea, sorry!

Starks
November 21st, 2009, 12:34 AM
Lack of good drivers across all operating systems makes the GMA500 a miserable platform to work with.

jbernardo
November 21st, 2009, 06:50 AM
There seems to be a whole new driver architecture on the works, according to Phoronix, but until then it would be nice to use the older one.

Anyway, my netbook is broken now - coffee on the keyboard. Will have to send it to repair next Monday, so probably won't have it back until next year.

mrdoob
November 27th, 2009, 01:55 AM
Lucazade script worked very well on Karmic. Worth a try?

http://swiss.ubuntuforums.org/showpost.php?p=8182373&postcount=87

Thanks Lucazade!

nontitle
December 11th, 2009, 02:51 PM
You had the same problem I did.

Albeit I am running gentoo on a 2.6.32 kernel, it shouldn't make a difference. (If it does, I was using psb-kmod version 4.41.1_p10 from portage)

Basically, it requires someone to patch the source code.
First, there is a compile error in drm_agpsupport.c
The line in question is
mem->pages[mem->page_count++] = phys_to_gart(page_to_phys(*cur_page));
, which appears to be line 527
Go back up to where the function starts (should be 509) and add the like
#define phys_to_gart(x) (x) (I'm sure you can just get rid of phys_to_gart entirely, but this is what I did)

The second bug in the source code that I get is in drm_edid.c
The line in question is
printk(KERN_ERR PREFIX "Invalid _DDC data\n"); which is line 42, however PREFIX is not defined anywhere. I'm not sure what it is supposed to be per se, but it should allow you to define it as anything, so adding
#define PREFIX "PSB(edid) " on line 17 should fix that.

Hopefully someone could get this patched, as I am busy for the next while. If nobody can make a build then I probably will be able to eventually, but not for at least a couple of weeks.

jbernardo
December 11th, 2009, 03:29 PM
I've done something similar to that already, and have uploaded a deb with the patch on this thread (http://ubuntuforums.org/showthread.php?p=8468379#post8468379). The patch was taken from a gentoo mailing list... :)

It removes the phys_to_gart, and replaces that PREFIX entry with "ACPI: ".

jbernardo
December 17th, 2009, 03:16 PM
Finally I got lucid to install on my 1101ha. And found out that now I can't get poulsbo drivers working due to a conflict between xserver-xorg-core from lucid repositories and xserver-xorg-video-psb from either Lucazade's or ubuntu-mobile PPAs.

Oh well...

brauliobo
March 17th, 2010, 02:46 AM
Same conflict here with Lucid.

brauliobo
March 17th, 2010, 02:54 AM
Lucazade, the package xserver-xorg-video-psb failed to build on PPA?