PDA

View Full Version : [ubuntu] Ubuntu one asking for keyring



gabe17
November 17th, 2009, 09:54 AM
Hi, I am using Ubuntu One (ehm, I am just starting), and everytime I log in to Ubuntu, it shows me a window like on the screenshot included...it wants from me a keyring. Why does it wan't? And what can I do that this window not to be shown everytime I log in to the system? Sorry for noob question and thanks for help.

pootan
November 18th, 2009, 11:46 AM
I had a similar issue with Ubuntu One asking for access whenever I sent or received emails. It's very annoying that Ubuntu One/Couch Desktop/CouchDB tries to integrate itself into everything without first asking if I want it to.

I found the best solution for me was to remove Ubuntu One, Couch Desktop and Couchdb and the 4 or 5 dependencies that show up with it(one of which is python related) until they can come up with an unobtrusive Cloud computing solution.

pixelmuerto
November 19th, 2009, 11:59 PM
I have same problem,
how I can add a application to the keyring ?

many thanks.

pixelmuerto
November 20th, 2009, 12:03 AM
pootan,
don't remove ubuntuOne of system, only remove of list of applitation in begin system.

System > preferences > "application in begin"

gabe17
November 23rd, 2009, 07:41 AM
I've removed it from application in begin. Thanks for your advice.

joshuahoover
November 24th, 2009, 03:26 PM
Hi, I am using Ubuntu One (ehm, I am just starting), and everytime I log in to Ubuntu, it shows me a window like on the screenshot included...it wants from me a keyring. Why does it wan't? And what can I do that this window not to be shown everytime I log in to the system? Sorry for noob question and thanks for help.

This will occur when using Ubuntu One in one of two scenarios:

1) You are setup with auto-login
2) Your keyring password is different than your login password

For #1, I suggest users setup a login and then you'll only have to login once. All applications requesting access to the keyring will have access as long as the keyring password and login password are the same.

For #2 you can open Applications->Accessories->Passwords And Encryption Keys, right-click on the "Passwords" folder and select "Change password". Change the password to match your login password.

Thank you,

Joshua

artm
December 8th, 2009, 10:35 AM
That defies the whole purpose of the auto-login option. If I configure my user to auto-login, it means I don't want to type in passwords period. May be this is the computer inside my secret underground lair, if the enemy managed to get to it, it's too late to protect ubuntu one from them: I'm most probably already dead anyway.

joshuahoover
December 15th, 2009, 06:28 PM
That defies the whole purpose of the auto-login option. If I configure my user to auto-login, it means I don't want to type in passwords period. May be this is the computer inside my secret underground lair, if the enemy managed to get to it, it's too late to protect ubuntu one from them: I'm most probably already dead anyway.

True, but this isn't just Ubuntu One. This is going to happen with any application that uses the keyring.

nimrodmilo
December 19th, 2009, 01:14 PM
I didn't really understood the process advised for the first scenario, should I login only once with my regular login ? or should I just disable the autologin for good ?

sofasurfer
December 19th, 2009, 10:13 PM
I don't know what is meant by "Ubuntu One".
I have Ubuntu 8.10. I disabled login but I still have to enter my password for keyring in order for wireless network to connect.
How can I eliminate this password request?
Like the other guy said, the Soviets have already entered my National Security computer. Its just a matter of time before they crack the password for internet access. Lets just eliminate that security layer.
How?