PDA

View Full Version : [SOLVED] fstab: full permissions



TironN
November 16th, 2009, 10:39 AM
hey i want to add fstab a partition in. I had it working before but read-write priviledges were only for root. I want this for all users. Its FAT32. What would I use to do this?

Zoot7
November 16th, 2009, 10:46 AM
sudo chmod -R 777 <where device is mounted>

Should do the job.

TironN
November 16th, 2009, 10:48 AM
Sad to say it but I think i read somewhere that if its FAT chmod won't work... hmmmm I'll try it again though

CaptainMark
November 16th, 2009, 10:50 AM
https://help.ubuntu.com/community/Fstab
should have everything you need

adding rw will give read/write privilidge. the options are the same for mount commands so pop 'man mount' into a terminal

TironN
November 16th, 2009, 11:02 AM
Ok.

So what I have written is:

/dev/sda2 /media/bigd auto rw,user,auto,exec 0 0

now it works but is still only giving root permission for write and mounting/unmounting

hal10000
November 16th, 2009, 11:43 AM
1.) you have to be a member of the group plugdev (gid 46 on my system). You can set this with your user-admin tool.

2.) make your fstab entry look like this:

/dev/sda2 /media/bigd vfat utf8,umask=007,gid=46 0 1

3.) unmount and remount /dev/sda2:

sudo umount /dev/sda2
sudo mount /dev/sda2

TironN
November 16th, 2009, 11:56 AM
Hey, its all working finally. umask was all it needed!

3rdalbum
November 16th, 2009, 12:21 PM
Sad to say it but I think i read somewhere that if its FAT chmod won't work... hmmmm I'll try it again though

It does if you're chmodding the mount point itself, because the mount point is a folder sitting on a Linux filesystem.