PDA

View Full Version : [ubuntu] 7.10 to 9.10, ethernet and wireless both dead



JlyGrnMigt
November 16th, 2009, 05:00 AM
I know the wireless doesn't work because I have a Broadcom card, and Ubuntu wants to get the driver. I plugged in an ethernet cord and it looks like it tried to detect the wired connection but was unsuccessful. I actually don't know if it worked before the upgrade, since I haven't booted into Ubuntu it a VERY long time.

I added a connection and manually typed in the MAC address for my router to see if that would do anything, but it did not. I'm back in the XP half of my computer, and the device manager is telling me that I have a Realtek RTL8319/810X Family Fast Ethernet NIC.

JlyGrnMigt
November 16th, 2009, 04:31 PM
I know the wireless doesn't work because I have a Broadcom card, and Ubuntu wants to get the driver.

So I've been working on the wireless issue since there seems to be more info about that floating around. I've managed to figure out which Broadcom card I have, but now I'm stuck. PLEASE correct me if I'm wrong, but all of the instructions here: http://linuxwireless.org/en/users/Drivers/b43#fw-b43-lp seem to assume that an ethernet connection is active.

My method at this point is putting stuff I need on a USB drive to move back and forth, so I need to know where to stick the files I get and how to tweak the code in those instructions to reflect that.

Iowan
November 17th, 2009, 12:32 AM
At the risk of taking you off on a tangent...
With wired interface connected, what are results (from a terminal) of
lshw -C network? I presume ifconfig -a shows no IP address for eth0...

JlyGrnMigt
November 17th, 2009, 05:27 PM
Thank you for replying! Here's the output. Sorry if the formatting is all cracked out - it's the result of things moving from gedit to notepad to here. I tried to get the breaks in the right spots.

elisa@elisa-laptop:~$ lshw -C network
WARNING: you should run this program as super-user.
*-network:0
description: Ethernet interface
product: RTL-8139/8139C/8139C+
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:05:00.0
logical name: eth0
version: 10
serial: 00:c0:9f:d3:fb:05
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical
configuration: broadcast=yes driver=8139too driverversion=0.9.28 latency=64 maxlatency=64 mingnt=32 multicast=yes
resources: irq:18 ioport:a000(size=256) memory:c0208000-c02080ff


*-network:1
description: Network controller
product: BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
vendor: Broadcom Corporation
physical id: 2
bus info: pci@0000:05:02.0
version: 02
width: 32 bits
clock: 33MHz
capabilities: bus_master
configuration: driver=b43-pci-bridge latency=64
resources: irq:20 memory:c0204000-c0205fff

*-network DISABLED
description: Wireless interface
physical id: 2
logical name: wlan0
serial: 00:14:a5:1a:ce:e3
capabilities: ethernet physical wireless
configuration: broadcast=yes multicast=yes wireless=IEEE 802.11bg

elisa@elisa-laptop:~$ ifconfig -a
eth0
Link encap:Ethernet HWaddr 00:c0:9f:d3:fb:05
inet6 addr: fe80::2c0:9fff:fed3:fb05/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
RX bytes:0 (0.0 B) TX bytes:2178 (2.1 KB)
Interrupt:18 Base address:0xa000

lo
Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)

wlan0
Link encap:Ethernet HWaddr 00:14:a5:1a:ce:e3
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wmaster0
Link encap:UNSPEC HWaddr 00-14-A5-1A-CE-E3-00-00-00-00-00-00-00-00-00-00
[NO FLAGS] MTU:0 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Iowan
November 18th, 2009, 04:42 AM
/etc/network/interfaces should have only two lines defining "lo". Anything else in that file? Try commenting out the extra lines (leave the "lo" lines alone) and restarting/rebooting.

JlyGrnMigt
November 24th, 2009, 05:08 PM
Nope, it only has 2 lines.


auto lo
iface lo inet loopback