PDA

View Full Version : [ubuntu] how to fully remove Ubuntu boot manager and install it again?



legolas_w
November 14th, 2009, 07:59 PM
Hi
Thank you for reading my post

Because of some problems in ubuntu boot sequence (it does not show the boot splash after I select the os and instead it shows the command line things) I want to fully remove the boot manager and install it from the beginning.

is that possible?


Thanks

Paqman
November 15th, 2009, 03:53 PM
is that possible?


Sure, but it probably won't fix your issue.

If the boot sequence is showing text at any point, the something is not quite right on your system. Check the logs and see if there's any errors being thrown up during boot.

legolas_w
November 15th, 2009, 09:15 PM
Hi
Which log files I should check? is there any diagnosis tools to help me with that?

Also, my GRUB version is 1.97_beta4 (it is shown on top of the os selection menue) is that the latest version?


Thanks.

Paqman
November 16th, 2009, 10:16 AM
Hi
Which log files I should check? is there any diagnosis tools to help me with that?


Take a look at System > Admin > System log viewer, particularly dmesg. If you want, you can post it here and have someone look over it for you.



Also, my GRUB version is 1.97_beta4 (it is shown on top of the os selection menue) is that the latest version?


Yep.

garvinrick4
November 16th, 2009, 11:20 AM
Isn't there a setting for boot splash or show text during boot. Just select show boot splash.

It is in the Start-up Manager in Applications. I do not think boot manager is the problem.

If you want splash and no text.

garvinrick4
November 16th, 2009, 11:26 AM
To uninstall a package is "sudo apt-get remove package name"

To clean cache of package "sudo apt-get clean"

To reinstall "sudo apt-get install package name"

update system "sudo apt-get update && sudo apt-get upgrade"

All without quotes.



System keeps packages in a cache. If you just remove and reinstall getting same package.

clean cache will allow you to fetch a new one from repositories.

3rdalbum
November 16th, 2009, 12:27 PM
Removing and reinstalling a program only solves problems if the problem involves the program's binary being corrupted. On Linux, that's very very rare.

In this case, all that's wrong is that your kernel line in GRUB does not have the "quiet splash" option in it. This option makes the booting "quiet" (no text) and gives you the picture (splash). Add those two words to the kernel line in your GRUB menu, and all will be well.

legolas_w
November 16th, 2009, 08:27 PM
Hi

Here is the content of grub file:





# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entrys
#GRUB_DISABLE_LINUX_RECOVERY="true"



and here is the content of the grub.cfg file:



#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s /boot/grub/grubenv ]; then
have_grubenv=true
load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
saved_entry=${prev_saved_entry}
save_env saved_entry
prev_saved_entry=
save_env prev_saved_entry
fi
insmod ext2
set root=(hd0,1)
search --no-floppy --fs-uuid --set 23caec3b-2cf8-4824-ac78-f36480daf57b
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=640x480
insmod gfxterm
insmod vbe
if terminal_output gfxterm ; then true ; else
# For backward compatibility with versions of terminal.mod that don't
# understand terminal_output
terminal gfxterm
fi
fi
if [ ${recordfail} = 1 ]; then
set timeout=-1
else
set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/white
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry "Ubuntu, Linux 2.6.31-14-generic-pae" {
recordfail=1
if [ -n ${have_grubenv} ]; then save_env recordfail; fi
set quiet=1
insmod ext2
set root=(hd0,1)
search --no-floppy --fs-uuid --set 23caec3b-2cf8-4824-ac78-f36480daf57b
linux /boot/vmlinuz-2.6.31-14-generic-pae root=UUID=23caec3b-2cf8-4824-ac78-f36480daf57b ro quiet splash
initrd /boot/initrd.img-2.6.31-14-generic-pae
}
menuentry "Ubuntu, Linux 2.6.31-14-generic-pae (recovery mode)" {
recordfail=1
if [ -n ${have_grubenv} ]; then save_env recordfail; fi
insmod ext2
set root=(hd0,1)
search --no-floppy --fs-uuid --set 23caec3b-2cf8-4824-ac78-f36480daf57b
linux /boot/vmlinuz-2.6.31-14-generic-pae root=UUID=23caec3b-2cf8-4824-ac78-f36480daf57b ro single
initrd /boot/initrd.img-2.6.31-14-generic-pae
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###


I can not understand why the boot splash is not show. If you have few minutes, please take a look and let me know if you spotted any problem.


Thanks.

legolas_w
November 17th, 2009, 02:10 PM
Hello everyone,


I was able to fix the thing to a point where it does not shows the text message and instead the screen goes black.

But I am still unable to make it show the splash screen.

I used startupmanager to do this.

Thanks,