PDA

View Full Version : [SOLVED] 9.10 Sound settings revert to mute upon startup



AlexOslo
November 14th, 2009, 07:57 PM
I just installed 9.10. The Output volume sound under Preferences -> Sound reverts to mute at every startup.
What can I do to make it keep my settings?

coldReactive
November 14th, 2009, 08:50 PM
You too? I thought it was only me.

bwzz
November 14th, 2009, 09:01 PM
I noticed that too, but didn't really bother me!

Sir Jasper
November 14th, 2009, 09:19 PM
Hi,

Search the word mute where answers were given within the last few days.

My regards

coldReactive
November 14th, 2009, 09:24 PM
Hi,

Search the word mute where answers were given within the last few days.

My regards

I searched, but most people are having issues with older versions (which I don't) or wanting to mute on start up when we want sound to work on start up.

I have yet to see a topic similar to this one on the first page of the mute search in absolute beginner talk. The last few on page one of the search were from a week ago, which is not "a few days."

mvalviar
November 14th, 2009, 09:27 PM
Having the same problem. I tried a number of guides already. None of them fixed my issue.

My box doesn't boot with muted audio all the time but it is still annoying. My volume should always be where I left it.

Sir Jasper
November 14th, 2009, 11:06 PM
Hi,

At:
/etc/init.d/alsa-utils
Near the end of the file and inset - do you see the line:
$TARGET_CARD" || EXITSTATUS=1
If you do:
sudo gedit /etc/init.d/alsa-utils
Comment out the above line by putting a # in front so:
#$TARGET_CARD" || EXITSTATUS=1
then save

That was effectively the recent solution (which I too did not find again).
Let us know how you all fare.

My regards

coldReactive
November 14th, 2009, 11:14 PM
TARGET_CARD doesn't have its own line like that:


# If a card identifier is provided in $2 then regard it as an error
# if that card is not present; otherwise don't regard it as an error.

case "$1" in
start)
EXITSTATUS=0
TARGET_CARD="$2"
case "$TARGET_CARD" in
""|all) TARGET_CARD=all ; log_action_begin_msg "Setting up ALSA" ;;
esac
if ! card_OK "$TARGET_CARD"; then
[ "$TARGET_CARD" = "all" ] && log_action_end_msg "$( [ ! "$2" ] ; echo $? ; )" "none loaded"
exit $?
fi
preinit_levels "$TARGET_CARD" || EXITSTATUS=1
if ! restore_levels "$TARGET_CARD" ; then
sanify_levels "$TARGET_CARD" || EXITSTATUS=1
restore_levels "$TARGET_CARD" >/dev/null 2>&1 || :
fi
[ "$TARGET_CARD" = "all" ] && log_action_end_msg_and_exit "$EXITSTATUS"
exit $EXITSTATUS
;;
stop)
EXITSTATUS=0
TARGET_CARD="$2"
case "$TARGET_CARD" in
""|all) TARGET_CARD=all ; log_action_begin_msg "Shutting down ALSA" ;;
*) log_action_begin_msg "Shutting down ALSA card ${TARGET_CARD}" ;;
esac
card_OK "$TARGET_CARD" || log_action_end_msg_and_exit "$( [ ! "$2" ] ; echo $? ; )" "none loaded"
store_levels "$TARGET_CARD" || EXITSTATUS=1
mute_and_zero_levels "$TARGET_CARD" || EXITSTATUS=1
log_action_end_msg_and_exit "$EXITSTATUS"
;;
restart|force-reload)
EXITSTATUS=0
$0 stop || EXITSTATUS=1
$0 start || EXITSTATUS=1
exit $EXITSTATUS
;;
reset)
TARGET_CARD="$2"
case "$TARGET_CARD" in
""|all) TARGET_CARD=all ; log_action_begin_msg "Resetting ALSA" ;;
*) log_action_begin_msg "Resetting ALSA card ${TARGET_CARD}" ;;
esac
card_OK "$TARGET_CARD" || log_action_end_msg_and_exit "$( [ ! "$2" ] ; echo $? ; )" "none loaded"
preinit_levels "$TARGET_CARD"
sanify_levels "$TARGET_CARD"
log_action_end_msg_and_exit "$?"
;;
*)
echo "Usage: $MYNAME {start [CARD]|stop [CARD]|restart [CARD]|reset [CARD]}" >&2
exit 3
;;
esac

There are four results for that phrase though.

Sir Jasper
November 14th, 2009, 11:35 PM
Hi,

Perhaps it should be the line:

#mute_and_zero_levels "$TARGET_CARD" || EXITSTATUS=1

If that is not it try a search ¨EXITSTATUS=1

My regards

PS My memory is not what it used to be, but the solution was very recent.

AlexOslo
November 15th, 2009, 02:39 PM
The Output volume sound under Preferences -> Sound reverts to mute at every startup.
What can I do to make it keep my settings?
It seems that in Sound -> Output, setting the Connector to Analog Output (LFE)/ Amplifier (from Analog Output/ Amplifier) has solved the problem.

AlexOslo
November 15th, 2009, 09:55 PM
It seems that in Sound -> Output, setting the Connector to Analog Output (LFE)/ Amplifier (from Analog Output/ Amplifier) has solved the problem.
Sorry, that "fix" was temporary, the next time it reverted to mute again. But I followed Sir Jasper's instructions,



At:
/etc/init.d/alsa-utils
Near the end of the file and inset - do you see the line:
$TARGET_CARD" || EXITSTATUS=1
If you do:
sudo gedit /etc/init.d/alsa-utils
Comment out the above line by putting a # in front so:
#$TARGET_CARD" || EXITSTATUS=1
then save
and it looks to have done the trick!

iceman85
November 28th, 2009, 12:18 AM
Hi,

At:
/etc/init.d/alsa-utils
Near the end of the file and inset - do you see the line:
$TARGET_CARD" || EXITSTATUS=1
If you do:
sudo gedit /etc/init.d/alsa-utils
Comment out the above line by putting a # in front so:
#$TARGET_CARD" || EXITSTATUS=1
then save

That was effectively the recent solution (which I too did not find again).
Let us know how you all fare.

My regards

Sir Jasper thanks for the solution!I confirm that everything it works! But is better to specify that is it necessary to edit all the lines "$TARGET_CARD" || EXITSTATUS=1" of the file. ;)

n6yga
January 17th, 2010, 05:44 PM
The actual line to comment out is:

mute_and_zero_levels "$TARGET_CARD" || EXITSTATUS=1

This worked for me on my Soundblaster Audigy SE

Mark.

papias
January 24th, 2010, 02:44 PM
The actual line to comment out is:

mute_and_zero_levels "$TARGET_CARD" || EXITSTATUS=1

This worked for me on my Soundblaster Audigy SE

Mark.

___________


ok for me!

strobe
April 7th, 2010, 01:34 AM
The actual line to comment out is:

mute_and_zero_levels "$TARGET_CARD" || EXITSTATUS=1This worked for me on my Soundblaster Audigy SE

Mark.

In case ppl are still checking... this fixed me too on Xubuntu-Karmic. Thnx.

baleks
April 25th, 2010, 01:20 PM
Unfortunately, in lucid there is no /etc/init.d/alsa-utils, there is only /sbin/alsa-utils
When i run /sbin/alsa-utils start, it restores alsa mixer settings, so my solution is to add "/sbin/alsa-utils start" to the /etc/rc.local

baleks
April 25th, 2010, 06:33 PM
It seems that in Sound -> Output, setting the Connector to Analog Output (LFE)/ Amplifier (from Analog Output/ Amplifier) has solved the problem.

Hmm.. That work for me even after rebooting!

cuberts
April 25th, 2010, 07:16 PM
I searched, but most people are having issues with older versions (which I don't) or wanting to mute on start up when we want sound to work on start up.

I have yet to see a topic similar to this one on the first page of the mute search in absolute beginner talk. The last few on page one of the search were from a week ago, which is not "a few days."I am also haveing the same problem on alsamixer, and master m always foes back to muted. What can we do?

baleks
April 25th, 2010, 07:22 PM
I am also haveing the same problem on alsamixer, and master m always foes back to muted. What can we do?

If you have pulseaudio you can try solution that i quoted in #17 reply
Else - you must run /etc/init.d/alsa-utils or /sbin/alsa-utils as system starts (you must install alsa-utils package) - it restores the mixer to saved state.
Try to add it using sysv-rc-conf utility (run as root) to runlevel 2,3,4,5 and reboot

apuglisi
July 19th, 2010, 03:02 AM
I had the same problem with my Acer Aspire 5542.

I managed to solve my problem for now this way:

sudo alsactl store 0 <--- to store alsa controls state to disk for the card 0
alsactl restore 0 <---- to restore from the saved state for the card 0

Then I created an item in the Startup Items control panel using the second command.

I need to find a way to save the state at shut down time to solve the complete problem. But at least this is a start.
Hope it helps some of you guys too.

lidex
July 19th, 2010, 03:24 AM
First try these terminal commands:

sudo mv /etc/rc0.d/K50alsa-utils /etc/rc0.d/S50alsa-utils
sudo mv /etc/rc6.d/K50alsa-utils /etc/rc6.d/S50alsa-utils

Reboot

No help?
Open this file for editing:

gksudo gedit /etc/pulse/default.pa
Scroll down to this line:

load-module module-device-restore
Comment it out so it looks like this:

#load-module module-device-restore
Save. Close. Logout/in.

No help? Comment out line 372 in /etc/init.d/alsa-utils
Should look like this when you're done:

# mute_and_zero_levels "$TARGET_CARD" || EXITSTATUS=1