PDA

View Full Version : Trouble Deleting Files 9.10



felizcortez
November 8th, 2009, 10:06 PM
I just did a clean install of 9.10 last night and am having trouble deleting recordings after watching them. In "Watch Recordings" menu I put hit "i" and then delete recording. This removes the recording on that screen initially, but if I leave the watch recordings menu and come back the program reappears as if it was never deleted. Another piece of information is that after I delete a recording the Television show title is still present (not removed). For Example, if I delete a recording of The Office named Office Olympics, then the title The Office still shows up as a menu, but the recording is no longer there. When i come back to Watch recordings later, the original recording reappears. Logs are below. Any help would be appreciated.

http://mythbuntu.pastebin.com/f50353206

SiHa
November 8th, 2009, 10:16 PM
Sounds like a permissions issue.

I had this when I installed 9.10. I imported some old recordings, and found that I couldn't delete them afterwards.

what does
ls -al /var/lib/mythtv/recordingsgive?

Or, do you have 'Auto-Expire instead of delete' checked in the frontend setup?

jMon54
January 23rd, 2010, 01:59 PM
I am having this same issue. Has anyone found a fix? In my case, if I wait awhile before moving on to the next screen or item to delete, it will stay deleted. And I think the bigger the file the longer it takes. But it is frustrating to see the recording disappear off the screen after hitting delete, then have it re-appear next time I visit the screen. And it is not a permissions issue. In 9.04, when I deleted a recording, I could see the system was taking a while to do it. Now it seems as if it's doing nothing. Whether I do it from Mythtv or from Mythweb the behavior is the same.

newbie02
January 24th, 2010, 01:42 AM
Having same issue. I have at most keep X number of episodes which is helping but from what I am seeing all over the net about this issue is for some people this will continue until the drive becomes full.

I am going to manually delete the recording for now.

newbie02

jaakan
January 24th, 2010, 06:41 PM
sounds like slow delete is on

jMon54
January 28th, 2010, 09:30 PM
sounds like slow delete is on

Thanks! Turning it off worked for me! Much obliged!!

geolizardo
February 18th, 2010, 09:27 AM
I looked through the setup and I could not find a slow delete setting. May I ask where I could find this?

Thanks very much!

novellahub
February 18th, 2010, 01:23 PM
I looked through the setup and I could not find a slow delete setting. May I ask where I could find this?

Thanks very much!

The slow delete setting is under mythtv-setup. Under the general settings.

mbleslie
March 7th, 2010, 09:55 PM
This was exactly the problem I was having as well. With slow delete turned off and while using mythweb, I could actually delete recordings. I made sure that I wasn't set to auto-expire but actually to delete. I did notice that if I was trying to delete a bunch of recordings quickly, they would eventually all get deleted but some took a couple of tries. I think the backend was busy doing the delete when I refreshed my recordings list.

Nevertheless, I freed up 400GB of space that was all winter olympics!

Ubu_Fester
September 24th, 2010, 03:45 AM
I was having the same problem.
Unchecking slow delete also worked for me.

ian dobson
September 24th, 2010, 06:01 AM
Hi,

The slow delete option is there for a good reason. If you have your recordings on a ext3 file system, deleting large files takes forever and a day, which blocks the mythtv-backend. With the slow delete option enabled the backend truncates the recording (chops off the end from the file) until it's small enough and then deletes the rest of the file.

ext4/xfs/jfs doesn't have this problem. If your using ext3 but your kernel supports ext4 you can just change your fstab to mount the filesystem using ext4. Although this won't make use of all the ext4 improvements (extents etc) it'll use all improvements that don't change the file structure on disk.

Regards
Ian Dobson