PDA

View Full Version : [ubuntu] 9.10 USB automount issues, more details/clues



scoobienoobienoo
November 5th, 2009, 03:24 PM
OK folks, I've seen several posts on the automount issue, but no clear solutions. Here are some clues that I have from my testing:

Problem: USB external drives not automounting properly.
System: MSI GX630 laptop
OS: Ubuntu 9.10 32-bit; new install on new hard drive
Symptoms:


USB mouse and keyboard work properly, even when plugged into a USB hub.
2.5” WD SATA HD works fine and mounts properly when plugged into a USB 2.0 powered adaptor.
Drives that worked properly in Windows Vista prior do not work now..

USB thumb drive
WD Passport 320 GB (USB external HDD)
Seagate 320 GB (USB external HDD)


When the system is restarted with the USB drives installed, they are mounted properly
All devices show using “lsusb” command



Applied fix:


modified /etc/modules by adding “usb_storage” on its own line

USB thumb drive mounted after logging out and back in, but no USB HDD's mount.
After restarting computer, USB thumb drive does not automount nor do the external drives
The 2.5” WD SATA HD always automounts when powered up via the USB/AC adaptor.




Still doesn't work. Any ideas?????