PDA

View Full Version : [ubuntu] Black screen in docking station with nVidia driver



laurac
November 3rd, 2009, 09:54 PM
I used envy to install the nVidia restricted driver on my laptop (running Hardy) in an attempt to get dual monitors working. When I rebooted with the system docked after installing the driver, I got a black screen. When I rebooted again with the laptop un-docked, everything works fine.

Any ideas what is going wrong? I'm including my xorg.conf file in case something in there is out of sorts.

Thanks!
-Laura


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Option "AddARGBGLXVisuals" "True"
Defaultdepth 24
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Inputdevice "Synaptics Touchpad"
EndSection

Section "Module"
Load "glx"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

konradsa
November 12th, 2009, 04:57 AM
Hi Laura,

I have the same problem. The only solution I found thus far is to flip the laptop open, and use System -> Administration -> Nvidia X Server Settings to manually activate the external monitor. There should be a way to save this configuration, but I have not gotten that far yet.

Edit:
You can save it to a configuration file using the "Save to X configuration file" button. If you get an error message, generate a new configuration file first with 'sudo nvidia-xconfig', and then run the settings tool with 'sudo nvidia-settings'.