PDA

View Full Version : Broken Dependencies



Khakilang
October 15th, 2009, 08:01 AM
Currently I been getting broken dependencies whenever I update or download software. Can anyone tell what is the problem? Attached is the screenshot below.

131992

Appreciate if anyone could help.

garvinrick4
October 15th, 2009, 08:12 AM
You have to tell the people what version you are using. Are you testing 9.10 doing
daily upgrades? Tell them your hardware video card, motherboard and such.
Some one has the answer if you give them something to go by. Good luck partner
and have a nice day.

wojox
October 15th, 2009, 08:14 AM
Looks like you need to install Firefox-3.0 first.

oboedad55
October 15th, 2009, 08:18 AM
Looks like you need to install Firefox-3.0 first.

It looks like the color scheme of karmic. Which version of Ubuntu are you using?

Susp
October 15th, 2009, 10:54 AM
Hi.

As I see, your Firefox is installed but is not configured properly.
One may name such package "Broken". So what I'll suggest you is to configure Firefox package, before trying to install anything which depends on it.
In order to do this open a terminal and try:


sudo dpkg-reconfigure firefox-3.0

Also I'd recommend you to check out what is going on by typing


aptitude

in your terminal. See if it reports broken packages or dependency problems.
Cheers

vipulkelkar
October 15th, 2009, 12:14 PM
try this in the terminal

sudo apt-get install -f