View Full Version : [ubuntu] 9800 GT installation fails every time

October 8th, 2009, 05:12 PM
Monitor: HP L1706
MOBO: XFX 750i dual SLI
Video: 2 Palit 9800 GT Sonic 512MB
RAM: Team Elite 2 x 2GB
CPU: Q8200 @ stock


I just installed ubuntu 9.04 32bit, I'm really having a hard time installing the driver for my 2 9800 GT .. These are the steps that I did.

My kernels: 2.6.28-11, 2.6.28-13, 2.6.28-15

1) downloaded and and installed both NVIDIA-Linux-x86-185.18.36-pkg1.run and NVIDIA-Linux-x86-173.14.12-pkg1.run.. (I stopped gdm before installing the driver). This steps failed so I had to uninstall.
2) Insalled from System>Administration>Hardware Drivers then activate. (Failed, then uninstalled from terminal then run the command apt-get autoremove)
3) Installed from Synaptic Package manager and selected nvidia-glx-173 (Failed, then uninstalled from terminal then run the command apt-get autoremove)

I really don't know what the problem is, I never had this problem before when I still had ubuntu 8.10 on my machine. And I'm getting frustrated everytime I get the same failing result, which is not being able to procceed to the desktop, just the terminal mode.

I hope there is anyone out there that can help me cuz I really like ubuntu rather than using Debian or OpenSuse..


Oh I think this is also a useful information, My xorg.conf:

# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"

October 9th, 2009, 02:43 AM
Hi and I have no experience with multiple graphics cards but this thread (http://ubuntuforums.org/showthread.php?t=884161)may help

October 9th, 2009, 04:42 AM
You might consider 64-bit. You won't get to use all 4GB of ram if you don't. I don't know if this would help but maybe Karmic which comes out on the 29th would let the drivers in the repository install.

Sorry I can't be of more help.

October 10th, 2009, 01:13 PM
Thanks for the help.. I already solved it :), I was'nt attentive enough to fix the problem, when I tried to add the my device configuration on xorg.conf, I mistakenly placed an dot rather than a colon ( ex. PCI:03:00.0 instead of a PCI:03:00:0 ) on both card configuration setting section on xorg.conf. Anyway, thanks for all the help..