PDA

View Full Version : Protocol version mismatch (frontend=50,backend=48)



tacman2k
October 6th, 2009, 03:53 AM
Hi everyone,

I'm running Mythbuntu 9.10 Beta with the lastest updates.

The last update broke my mythbox.

My mythfrontend.log revealed the following:

2009-10-05 21:42:33.989 MythContext: Connecting to backend server: 127.0.0.1:6543 (try 1 of 1)
2009-10-05 21:42:34.061 Protocol version mismatch (frontend=50,backend=48)


Is there anything I can do to get this back up and running?



--
Edit:

Running version checks lead to the following:

mythbackend --version
MythTV Version : 22242
MythTV Branch : trunk
Network Protocol : 50
Library API : 0.22.20091004-1
QT Version : 4.5.2


mythfrontend --version
MythTV Version : 22242
MythTV Branch : trunk
Network Protocol : 50
Library API : 0.22.20091004-1
QT Version : 4.5.2


Still have the problem though. Any solutions?

ian dobson
October 6th, 2009, 04:49 AM
Hi,

Wait a day or so then do another update. It looks as if the update "updated" your frontend but not the backend so they're nolonger running the same version.

It's still beta and things can go wrong sometimes.

Regards
Ian Dobson

Mitch_nl
October 6th, 2009, 02:38 PM
do a 'dpkg-reconfigure mythtv-database' to update the database scheme on the backend.