PDA

View Full Version : 5.1 sound works with DVD's, not with HDTV



Bloodrule
September 27th, 2009, 12:51 AM
I have MythTV set up with digital sound configured to spdif running 8.10 - playing DVD's produces sound to all speakers. Watching live or recorded HDTV (which includes a 5.1 sound channel) won't play to any other than right and left front speakers.

The fact that DVD's play correctly means the hardware and the Linux installation work - I assume I may be missing a configuration setting in MythTV itself.

Any ideas? Have tried endless variations of settings without success.

Thanks, BR.

jaakan
September 27th, 2009, 09:26 PM
I have MythTV set up with digital sound configured to spdif running 8.10 - playing DVD's produces sound to all speakers. Watching live or recorded HDTV (which includes a 5.1 sound channel) won't play to any other than right and left front speakers.

The fact that DVD's play correctly means the hardware and the Linux installation work - I assume I may be missing a configuration setting in MythTV itself.

Any ideas? Have tried endless variations of settings without success.

Thanks, BR.



Here are my settings for mythfrontend General Setup. 9.04 but I had the same settings when I had 8.10.

* AUDIO OUTPUT DEVICE = ALSA:default
* PASSTHROUGH OUTPUT DEVICE = ALSA:iec958:{ AES0 0x02 }
* MAX AUDIO CHANNELS = stereo
* UPMIX = passive
* X=Enable AC3 to SPDIF Passthrough
* X=Enable DTS to SPDIF Passthrough
* _=Aggressive Sound Card Buffering
* _=Use internal Volume Controls

Bloodrule
September 28th, 2009, 01:30 AM
Thanks for your reply. I got it working in the end by changing the audio settings to ALSA:spdif. Appreciate your help.