PDA

View Full Version : [ubuntu] Composite extension not available



gatordude
September 24th, 2009, 07:46 AM
Ok, (first I did search the forum on this and didnt find any thing that I thought would help) .My problem I am having is enabling desktop effects. When I intalled 9.04 (on a P$ 3G machine) with 1 monitor I could enable them. When I added the nvidia drivers (GeForce 8400 GS card) to enable the other monitor I get " The Composite extension is not available"
Please advise.

My config file:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Sun Feb 1 20:21:04 UTC 2009

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Mon Mar 23 15:33:27 PST 2009
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "1"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Acer AL2216W"
HorizSync 31.0 - 84.0
VertRefresh 56.0 - 77.0
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "Acer AL2216W"
HorizSync 47.0 - 84.0
VertRefresh 56.0 - 76.0
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8400 GS"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8400 GS"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
Option "NoLogo" "True"
SubSection "Display"
Depth 24
Modes "nvidia-auto-select"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "DFP: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "CRT: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "1"
EndSection

rreese6
September 24th, 2009, 04:59 PM
try adding this line in xorg.config:

Option "Composite" "Enable"
above Option "Composite" "1"

then reboot the server.

if this doesn't help
you may need to install
xserver-xgl to make it work

here is a link about xgl:
http://www.freedesktop.org/wiki/Software/Xgl

another good link:
http://wiki.archlinux.org/index.php/Xgl

gatordude
September 25th, 2009, 12:04 AM
I added that above where you stated and still no joy.

rreese6
September 25th, 2009, 03:14 AM
look into the xgl method from the links I posted.
That may be your only hope.
xgl will allow composite for multi-monitors.

gatordude
September 27th, 2009, 11:08 AM
OK, something weird happened. I shut off my PC and the next day when I turned it on I could use desktop effects?? And yes I did power down my system when I made the changes to the config file.

And after playing with them for a day I dont like them and turned them off.

Just to ask so I can be assured my system is working properly.

With desktop effects on and Compiz running does it make each monitor (in a dual setup) act as seperate desktops? I enjoy the capability of running docs and web browser windows from one side to another when i am doing research or what ever. The fact that I have to flip my desktops around is somewhat of a pain.

Am I supposed to be able to slide a window over from one screen to another or is that a shortfall of desktop effects?

Cheers