PDA

View Full Version : [kubuntu] Mscore (MuseScore) - no sound



peterroots
September 16th, 2009, 02:55 PM
Has anyone got mscore to play sound on kubuntu9.04?
I first got a problem that mscore could not access /dev/rtc (which points to /dev/rtc0) so I changed the file permissions from 600 to 666 and now mscore reports the following

Suspending PulseAudio
RtcTimer::setTimerFreq(): cannot set ticks 1024 on /dev/rtc: Permission denied
precise timer not available
MidiSeq:start(): no midi timer available
Cannot start I/O
sequencer init failed

some very old posts suggest
sudo sysctl -w dev.rtc.max-user-freq=1024
to fix the problem but I get back
error: "dev.rtc.max-user-freq" is an unknown key

Other posts suggest using a jack server but I don't especially want to install any other sound servers (using pulse at the moment and works for everything else)

I would be happy to get mscore working with either alsa or midi (noteedit works with midi, using timidity on my system)

If I set mscore to use Alsa it fails with this

Suspending PulseAudio
Alsa_driver: can't set sample rate to 0.
init ALSA audio driver failed
init ALSA driver failed
init audio driver failed
sequencer init failed

presumably because I can't get a sample rate value to stick in the mscore settings for alsa. The device is set to hw:0 which does stick but sample rate and period size can be set but vanish after restarting.

Any suggestions?

advocate 21
October 5th, 2009, 04:10 AM
i have the same problem, only with ubuntu 9.04, not kubuntu.
please help.

kuadra
October 9th, 2009, 10:11 AM
I've just checked my MuseScore setup. Under "Edit" -> "Preferences" -> "I/O", if I switch to "Use midi output", I get the same error as you've reported.
I've activated the "use internal synthesizer" and selected a sound font (in my case /usr/share/sounds/sf2/FluidR3_GM.sf2 from the package fluid-soundfont-gm). Furthermore, I've selected ALSA instead of Portaudio because I've not portaudio server running.

Hope it helps.

peterroots
December 12th, 2009, 07:43 PM
rather gave up on this but as I now have Kubuntu9.10 I thought I would revisit it.
still does not work
With Midi (using timidity which works with other things) I still get


peter@PeterLT:$ mscore
/usr/bin/mscore: 27: list: not found
Using JACK for audio
RtcTimer:: fatal error: open /dev/rtc failed: Permission denied
MidiSeq:start(): no midi timer available
Cannot start I/O
sequencer init failed

Despite what it says above I am NOT using jack, I don't have it installed and it is not selected in the i/o tab of mscore
If I chmod /dev/rtc0 (this is where /dev/rtc points to) I get this


peter@PeterLT:$ mscore
/usr/bin/mscore: 27: list: not found
Using JACK for audio
RtcTimer::setTimerFreq(): cannot set ticks 1024 on /dev/rtc: Permission denied
precise timer not available
MidiSeq:start(): no midi timer available
Cannot start I/O
sequencer init failed

if I select 'use internal synthsiser' and alsa (without selecting jack and with a sound font selected)


peter@PeterLT:$ mscore
/usr/bin/mscore: 27: list: not found
Using JACK for audio
Alsa_driver: can't set sample rate to 0.
init ALSA audio driver failed
init ALSA driver failed
init audio driver failed
sequencer init failed

I can select any value I like for sample rate and period size but they have always gone again after restarting mscore

aplay -l gives me this


peter@PeterLT:$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 0: Intel ICH [Intel 82801DB-ICH4]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 4: Intel ICH - IEC958 [Intel 82801DB-ICH4 - IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0


previously I was using pulse audio but when I did a fresh install of 9.10 pulse audio server was not installed (though the xine and gstreamer pulse plugins were)

Panserbjorne
December 23rd, 2009, 04:16 PM
I've read in another topic that in Preferences>I/O settings>
changing the ALSA Audio device from default to hw:0 solves the problem

...It works fine to me...
Greets!!

peterroots
December 23rd, 2009, 04:30 PM
Glad you have got it working, thanks for the tip.
Unfortunately for me, whether I use default or hw:0 for the alsa device I always get a failure with 'Alsa_driver: can't set sample rate to 0.'
Whatever value I enter for sample rate or period size vanish again after restarting Mscore

jamh
October 25th, 2011, 10:58 PM
What Peterroots said.

Also, add to your /etc/modules:
lp
sbp2
snd_seq

and restart.

peterroots
October 26th, 2011, 09:57 AM
Jamh
Thanks for your suggestion - I failed totally on Kubuntu 9.04 and 9.10 and removed Mscore.
With Kubuntu 11.04 and 11.10 Mscore works fine again for me, with no extra fiddling around to fix it. I have no idea if 10.04 or 10.11 worked though as I had Canorus installed then (which did work, and still does but I prefer Mscore)

hg21
November 26th, 2011, 04:51 PM
Sorry this is a bit off topic.

I can get sound OK but musescore is very unstable it crashes frequently. I cannot get the File>parts mechanism to work. Could you tell me if you are using 64bit Kubuntu. I wonder if that is my problem?

On 11.10 Kubuntu

Thanks
Howard

peterroots
November 26th, 2011, 06:26 PM
I have never used the parts bit on the file menu (I only do some very occasional mucking about with this). I just tried it and it seems to work, though not entirely sure what I should expect.
Whole thing seems stable enough (I have not had a crash) and I am using 64bit with timidity for midi output