PDA

View Full Version : [ubuntu] no "add computer" webpage



Findarato
September 14th, 2009, 09:24 PM
Hello everyone,

I have installed ubuntu one on my desktop and my laptop, both running ubuntu jaunty 9.04. The installation went flawless, but the last step is giving me a lot of trouble : adding a computer to start sharing files...

On the website, it is said that, once you have ubuntu-one installed, when you launch it the first time, you automaticaly get taken to a website to add your computer. The problem is that this does not happen with me and I cannot find ANY manual way to get to that page (no reference on the web I could find whatsoever).

I would appreciate it if someone knows the answer to this one.

Findarato

joshuahoover
September 15th, 2009, 02:52 PM
Hello everyone,

I have installed ubuntu one on my desktop and my laptop, both running ubuntu jaunty 9.04. The installation went flawless, but the last step is giving me a lot of trouble : adding a computer to start sharing files...

On the website, it is said that, once you have ubuntu-one installed, when you launch it the first time, you automaticaly get taken to a website to add your computer. The problem is that this does not happen with me and I cannot find ANY manual way to get to that page (no reference on the web I could find whatsoever).

I would appreciate it if someone knows the answer to this one.

Findarato

Hi Findarato,

I'm sorry to hear Ubuntu One isn't installing properly for you. Did you recently install the client? Please make sure you have the latest release, as that contains some important fixes. If you have the latest release, can you quit the client by right-clicking on the Ubuntu One applet and select quit, then try starting the client from a terminal session with: ubuntuone-client-applet

If there is an error, you should receive some info from starting the client there. If you don't, can you right-click on the Ubuntu One applet and select report a problem to file a bug report that will also attach some debug info.

Thanks!

Joshua

Findarato
September 15th, 2009, 04:25 PM
Problem has been reported already, this is what my terminal says:
Traceback (most recent call last):
File "/var/lib/python-support/python2.6/dbus/connection.py", line 578, in msg_reply_handler
reply_handler(*message.get_args_list(**get_args_op ts))
File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 251, in got_state
self.acquire_access_token(description, store)
File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 317, in acquire_access_token
callback=callback_url)
File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/oauth.py", line 286, in from_token_and_callback
parameters['oauth_token'] = token.key
AttributeError: 'NoneType' object has no attribute 'key'

Findarato
September 15th, 2009, 04:36 PM
To be clear, I have not even been able to link my client to my on-line subscription.

mnorwood154
September 16th, 2009, 04:45 AM
I have the exact same problem.

Ubuntu 9.04

Linux Ubuntu 2.6.28-15-generic #49-Ubuntu SMP Tue Aug 18 19:25:34 UTC 2009 x86_64 GNU/Linux

Findarato
September 16th, 2009, 01:02 PM
I am also under a 64 bit ubuntu, is that any indication ?

Findarato
September 17th, 2009, 01:15 PM
Bump

Findarato
September 17th, 2009, 11:27 PM
This is what the terminal gives me :

Traceback (most recent call last):
File "/var/lib/python-support/python2.6/dbus/connection.py", line 578, in msg_reply_handler
reply_handler(*message.get_args_list(**get_args_op ts))
File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 251, in got_state
self.acquire_access_token(description, store)
File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 317, in acquire_access_token
callback=callback_url)
File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/oauth.py", line 286, in from_token_and_callback
parameters['oauth_token'] = token.key
AttributeError: 'NoneType' object has no attribute 'key'

Findarato
September 18th, 2009, 08:24 AM
I went for a remove / purge / reinstall and now it works :)

joshuahoover
September 18th, 2009, 02:41 PM
My apologies for the delay in getting back to everyone here. We released an update on Wednesday that should remedy this problem. If you are still have trouble after updating to the latest client, please right-click on the Ubuntu One icon and select "Report a Problem". Thank you all for your patience and for the interest in Ubuntu One!

-Joshua

JaspSoft
October 17th, 2009, 05:46 PM
I've just downloaded this following the instructions here:
https://one.ubuntu.com/support/installation/

I'm on 9.04 and I can find no way at all to add a computer.

Psyphre
October 17th, 2009, 11:30 PM
Same, Jaunty 64 bits, cant add my computer because no webpage comes up.

:(

I installed in within the past hour, so its as up to date as you can get.

Here's my terminal output:


Traceback (most recent call last):
File "/var/lib/python-support/python2.6/dbus/connection.py", line 578, in msg_reply_handler
reply_handler(*message.get_args_list(**get_args_op ts))
File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 276, in got_state
self.acquire_access_token(description, store)
File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 336, in acquire_access_token
self.request_token = self.make_token_request(oauth_request)
File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 229, in make_token_request
fp = opener.open(oauth_request.http_url, oauth_request.to_postdata())
File "/usr/lib/python2.6/urllib.py", line 205, in open
return getattr(self, name)(url, data)
File "/usr/lib/python2.6/urllib.py", line 437, in open_https
h.endheaders()
File "/usr/lib/python2.6/httplib.py", line 868, in endheaders
self._send_output()
File "/usr/lib/python2.6/httplib.py", line 740, in _send_output
self.send(msg)
File "/usr/lib/python2.6/httplib.py", line 699, in send
self.connect()
File "/usr/lib/python2.6/dist-packages/ubuntuone/oauthdesktop/auth.py", line 58, in _connect_wrapper
if self._tunnel_host:
AttributeError: HTTPSConnection instance has no attribute '_tunnel_host'

Xavier Oddmon
October 19th, 2009, 04:25 AM
Same issue, on jaunty, 32 bit. no add computer web page. What's more, I checked the FAQs, and they mention not being able to connect to http://127.0.0.1:35782/. I also cannot connect to this URL, in firefox or opera, and don't have any firewall configured. I'm not even sure this is related though. If that's not the URL to go to, why can't there just be a button to add the computer :confused:

Psyphre
October 19th, 2009, 06:01 PM
This bug was filed on launchpad.

https://bugs.launchpad.net/ubuntuone-client/+bug/451670

They claim its been fixed in the new revision, though I don't know how to update to the latest revision so can't test it out.

If anyone knows how please let me know.

joshuahoover
October 20th, 2009, 06:30 PM
This bug was filed on launchpad.

https://bugs.launchpad.net/ubuntuone-client/+bug/451670

They claim its been fixed in the new revision, though I don't know how to update to the latest revision so can't test it out.

If anyone knows how please let me know.

We did put out a release yesterday that fixes bug 451670. In order to get this release, you can normally go to System->Administration->Update Manager. In Update Manager click on the "Check" button and once the update is done, click "Install Updates".

On the command line you can update by running: sudo apt-get update && sudo apt-get upgrade

Thank you,

Joshua

Psyphre
October 21st, 2009, 11:23 PM
We did put out a release yesterday that fixes bug 451670. In order to get this release, you can normally go to System->Administration->Update Manager. In Update Manager click on the "Check" button and once the update is done, click "Install Updates".

On the command line you can update by running: sudo apt-get update && sudo apt-get upgrade

Thank you,

Joshua

Hi, thanks alot I tried again shortly after my post and the update was there, I guess it just took a while for the update to appear :)

Got it working now!

Thanks again.

honzasvasek
November 18th, 2009, 09:29 PM
ubuntuone needs networkmanager installed and running.

sites
December 21st, 2009, 04:32 PM
ubuntuone needs networkmanager installed and running.

Since I'm using wicd, which removes network-manager upon installing, I suppose my hopes of running UbuntuOne are hosed.

Are there any plans to make this service work through wicd?

can0ne
February 1st, 2010, 11:01 PM
Since I'm using wicd, which removes network-manager upon installing, I suppose my hopes of running UbuntuOne are hosed.

Are there any plans to make this service work through wicd?

same problem.

joshuahoover
February 1st, 2010, 11:21 PM
same problem.

For those not using NetworkManager, we have a fix in.

Karmic (9.10) users should follow this FAQ: https://answers.edge.launchpad.net/ubuntuone-client/+faq/930

Jaunty (9.04) users should just do an update via Update Manager and install the latest Ubuntu One updates

Thanks,

Joshua

RavanH
February 5th, 2010, 08:05 PM
For those not using NetworkManager, we have a fix in.

Karmic (9.10) users should follow this FAQ: https://answers.edge.launchpad.net/ubuntuone-client/+faq/930

Jaunty (9.04) users should just do an update via Update Manager and install the latest Ubuntu One updates

Thanks,

Joshua

WOOOT ! !

Thanks Joshua, the proposed version did the trick :)

Even though the error
ERROR:dbus.proxies:Introspect error on org.freedesktop.NetworkManager:/org/freedesktop/NetworkManager: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files still shows, the client connects and syncs using Wicd like it used to with NM.

THANKS!

ralpyka
March 16th, 2010, 06:09 PM
I have a similar problem. (Sorry for my english)
I use Ubuntu 9.04. I recently reinstalled ubuntu and I installed ubuntuone. Was a problem with libhttp2, but i installed it, and ubuntu one started, but the sync did not worked. After i made a mistake, because on the ubuntuone webpage i removed all computers from the account. I reinstalled ubuntuone, but there is no "add computer" webpage. Can you give me some advice to what to do now?

joshuahoover
March 16th, 2010, 10:02 PM
I have a similar problem. (Sorry for my english)
I use Ubuntu 9.04. I recently reinstalled ubuntu and I installed ubuntuone. Was a problem with libhttp2, but i installed it, and ubuntu one started, but the sync did not worked. After i made a mistake, because on the ubuntuone webpage i removed all computers from the account. I reinstalled ubuntuone, but there is no "add computer" webpage. Can you give me some advice to what to do now?

Did you follow the latest instructions found at https://one.ubuntu.com/support/installation/ ? If so, you might want to try starting the the Ubuntu One preferences from a terminal session (Applications->Accessories->Terminal): ubuntuone-preferences

If you get an error there, please let me know. Also, make sure you have your preferred browser set in System->Preferences->Preferred Applications

Thank you,

Joshua

ralpyka
March 27th, 2010, 10:54 AM
I followed the latest instructions, to reinstall the client. The window appears, but the Name, Username, E-mail are all empty. I got an error message too:


DBusException(dbus.String(u'Traceback (most recent call last):\n File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/dbus_interface.py", line 1068, in set_throttling_limits\n aq.writeLimit = upload\n File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/client.py", line 1451, in _set_write_limit\n raise ValueError(\'Write limit must be greater than 0.\')\nValueError: Write limit must be greater than 0.\n'),)
I hope, that this is useful.

joshuahoover
March 29th, 2010, 10:27 PM
I followed the latest instructions, to reinstall the client. The window appears, but the Name, Username, E-mail are all empty. I got an error message too:


DBusException(dbus.String(u'Traceback (most recent call last):\n File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/dbus_interface.py", line 1068, in set_throttling_limits\n aq.writeLimit = upload\n File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/client.py", line 1451, in _set_write_limit\n raise ValueError(\'Write limit must be greater than 0.\')\nValueError: Write limit must be greater than 0.\n'),)
I hope, that this is useful.

This sounds like you need to remove ~/.config/ubuntuone/syncdaemon.conf and then restart the client. The best way to do this right now is to open a terminal session (Applications->Accessories->Terminal):

killall ubuntuone-syncdaemon
killall ubuntuone-login

Then open System->Preferences->Ubuntu One and see if you get the same error.

Thanks!

Joshua

ralpyka
March 31st, 2010, 03:37 PM
I deleted that file, what you said(~/.config/ubuntuone/syncdaemon.conf). When I start the client, I hasn't any error message, but the "add computer" webpage doesn't apper, everything is the same, as before(Name, Username, E-mail are still empty).
There is no other way to manually add my computer to the service?

EDIT: I solved my problem. Thank you for all the help.
I installed ubuntuone-client-tools, and with the u1sync --authorize command I could add my computer to the service. Now everything is going ok.

joshuahoover
March 31st, 2010, 10:39 PM
I deleted that file, what you said(~/.config/ubuntuone/syncdaemon.conf). When I start the client, I hasn't any error message, but the "add computer" webpage doesn't apper, everything is the same, as before(Name, Username, E-mail are still empty).
There is no other way to manually add my computer to the service?

EDIT: I solved my problem. Thank you for all the help.
I installed ubuntuone-client-tools, and with the u1sync --authorize command I could add my computer to the service. Now everything is going ok.

I'm happy to hear Ubuntu One is working for you now. You shouldn't have had to use u1sync to get things working. Based on the error you reported, it seemed like it didn't like the bandwidth throttling settings so deleting the ~/.config/ubuntuone/syncdaemon.conf and restarting Ubuntu One should have taken care of this problem. Strange.

Joshua

alpha-buntu
April 2nd, 2010, 09:57 PM
I deleted that file, what you said(~/.config/ubuntuone/syncdaemon.conf). When I start the client, I hasn't any error message, but the "add computer" webpage doesn't apper, everything is the same, as before(Name, Username, E-mail are still empty).
There is no other way to manually add my computer to the service?

EDIT: I solved my problem. Thank you for all the help.
I installed ubuntuone-client-tools, and with the u1sync --authorize command I could add my computer to the service. Now everything is going ok.

kind of lame - but that worked here!

mindaslab
April 7th, 2010, 02:50 AM
Have the same problem. I have stopped using Ubuntu one. I have got a thumb drive into which I backup every day! Life now seems so simple. Looks like Ubuntu one is a total failure.

flomar
April 15th, 2010, 09:01 AM
Same behavior on 10.04 Beta on my Thinkpad X200. I think maybe it has to do something with the fact that I was playing around with Ubuntu One on my Windows machine before.

Removal and Reinstalling Ubuntu One in the Software-Center solved the problem for me!

filister
April 25th, 2010, 06:55 PM
Hey guys, I'm using the new Ubunu 10.04 Beta II, and I found that there is not an add computer button in the ubuntu one ccount page. There is only remove selected computers from the list. So if for some reason you miss to click on authorize the computer to the account you won't benefit from this service. I tried to reinstall the client, I removed all the packages associated with ubuntu one in the Ubuntu Software Center, and reinstall it through the terminal with the command sudo aptitude install ubuntuone-client and now there is not an ubuntu one menu entry. I was not able to start it with the console either.

joshuahoover
April 27th, 2010, 08:13 PM
Hey guys, I'm using the new Ubunu 10.04 Beta II, and I found that there is not an add computer button in the ubuntu one ccount page. There is only remove selected computers from the list. So if for some reason you miss to click on authorize the computer to the account you won't benefit from this service. I tried to reinstall the client, I removed all the packages associated with ubuntu one in the Ubuntu Software Center, and reinstall it through the terminal with the command sudo aptitude install ubuntuone-client and now there is not an ubuntu one menu entry. I was not able to start it with the console either.

I'm sorry this process isn't as streamlined as it could be. We're working on fixing that, but in the time being, you should be able to open System->Preferences->Ubuntu One and then get prompted in a web browser window to add your computer to your Ubuntu One account. If this never happens, can you do the following?


Open Applications->Accessories->Passwords and Encryption Keys
If you have an UbuntuOne token (under Passwords: default), right-click and select delete
Open a terminal session (Applications->Accessories->Terminal) and run:
killall ubuntuone-login ubuntuone-syncdaemon
Open System->Preferences->Ubuntu One
A browser window should open and you should be prompted to add your computer

Thank you,

Joshua

gyterpena
April 28th, 2010, 10:24 AM
Hi Joshua

Your fix is not working there is no ubuntu-one menu item in system -> preferences.
Also tried to remove purge and install again.

Running 10.04 upgraded from 9.10

Thanks
Peter

Edit: Never mind above post managed to fixed it. When installing from CLI there was no menu entry but from software centre it worked. Only think missing at the moment is the tray icon.

heatpumpcontrol
April 28th, 2010, 04:38 PM
Open Applications->Accessories->Passwords and Encryption Keys
If you have an UbuntuOne token (under Passwords: default), right-click and select delete
Open a terminal session (Applications->Accessories->Terminal) and run:
killall ubuntuone-login ubuntuone-syncdaemon
Open System->Preferences->Ubuntu One
A browser window should open and you should be prompted to add your computer
[/LIST]
Thank you,

Joshua

This worked! thanks

joshuahoover
April 29th, 2010, 09:37 PM
Hi Joshua

Edit: Never mind above post managed to fixed it. When installing from CLI there was no menu entry but from software centre it worked. Only think missing at the moment is the tray icon.

Right, the tray icon is no more. :( You now can access Ubuntu One Preferences from the Lucid "Me menu" (your username in the task bar) or via System->Preferences->Ubuntu One

Thank you,

Joshua

technodenbow
April 29th, 2010, 10:04 PM
Same issue here as well. No option to select computer and sync. Ubuntu/Linux newbie so be gentle!

thebear78
April 30th, 2010, 05:05 AM
Same issue here as well. No option to select computer and sync. Ubuntu/Linux newbie so be gentle!

Just added some info about this issue and some instructions on how to resolve it to add your computers to Ubuntu One. It involved opening Terminal but it's only 1 command so don't be scared. http://bit.ly/caHbOf

catxk
April 30th, 2010, 01:45 PM
Just added some info about this issue and some instructions on how to resolve it to add your computers to Ubuntu One. It involved opening Terminal but it's only 1 command so don't be scared. http://bit.ly/caHbOf

This did it for me with Ubuntu 10.04, thanks.

jonny163
April 30th, 2010, 03:32 PM
I'm sorry this process isn't as streamlined as it could be. We're working on fixing that, but in the time being, you should be able to open System->Preferences->Ubuntu One and then get prompted in a web browser window to add your computer to your Ubuntu One account. If this never happens, can you do the following?


Open Applications->Accessories->Passwords and Encryption Keys
If you have an UbuntuOne token (under Passwords: default), right-click and select delete
Open a terminal session (Applications->Accessories->Terminal) and run:
killall ubuntuone-login ubuntuone-syncdaemon
Open System->Preferences->Ubuntu One
A browser window should open and you should be prompted to add your computer

Thank you,

Joshua

Thanks Joshua, this worked a treat for me in 10.04

joshuahoover
April 30th, 2010, 11:05 PM
Thanks Joshua, this worked a treat for me in 10.04

Good to hear! And thank you for following up here as it's helpful to others to know when something works (as well as when it doesn't.) :)

Joshua

essial
May 1st, 2010, 04:54 AM
I'm sorry this process isn't as streamlined as it could be. We're working on fixing that, but in the time being, you should be able to open System->Preferences->Ubuntu One and then get prompted in a web browser window to add your computer to your Ubuntu One account. If this never happens, can you do the following?


Open Applications->Accessories->Passwords and Encryption Keys
If you have an UbuntuOne token (under Passwords: default), right-click and select delete
Open a terminal session (Applications->Accessories->Terminal) and run:
killall ubuntuone-login ubuntuone-syncdaemon
Open System->Preferences->Ubuntu One
A browser window should open and you should be prompted to add your computer

Thank you,

Joshua

I created my Ubuntu one account via my laptop with a clean x86 install of Ubuntu 10.04, and the process went flawlessly. When I then tried to add my cleanly installed x86_64 Ubuntu 10.04 desktop to Ubuntu one I had the same issue (no add button). Doing the above fixes the problem. I truly hope you guys fix this issue ASAP as Ubuntu One will be a great way for you to get even more revenue to continue developing such an amazing Linux distribution!

pope1701
May 1st, 2010, 06:48 AM
After a clean install of 10.04 it didn't work with my standard browser set to opera.

After resetting standard browser to Firefox and following this guide (http://https://wiki.ubuntu.com/UbuntuOne/FAQ#How do I add my computer?) it worked. Maybe this should be mentioned somewhere. :)

Thank you!

Fuchur777
May 1st, 2010, 06:39 PM
This sounds like you need to remove ~/.config/ubuntuone/syncdaemon.conf and then restart the client. The best way to do this right now is to open a terminal session (Applications->Accessories->Terminal):

killall ubuntuone-syncdaemon
killall ubuntuone-login

Then open System->Preferences->Ubuntu One
Thanks!

Joshua

This worked perfectly for me with my error not getting add computer page in Lucid Lynx!

lotharmat
May 1st, 2010, 07:39 PM
I'm sorry this process isn't as streamlined as it could be. We're working on fixing that, but in the time being, you should be able to open System->Preferences->Ubuntu One and then get prompted in a web browser window to add your computer to your Ubuntu One account. If this never happens, can you do the following?


Open Applications->Accessories->Passwords and Encryption Keys
If you have an UbuntuOne token (under Passwords: default), right-click and select delete
Open a terminal session (Applications->Accessories->Terminal) and run:
killall ubuntuone-login ubuntuone-syncdaemon
Open System->Preferences->Ubuntu One
A browser window should open and you should be prompted to add your computer

Thank you,

Joshua

This worked for me! - Thanks Joshua

Now - If only it would synch my files!

emagine
May 1st, 2010, 09:43 PM
I'm sorry this process isn't as streamlined as it could be. We're working on fixing that, but in the time being, you should be able to open System->Preferences->Ubuntu One and then get prompted in a web browser window to add your computer to your Ubuntu One account. If this never happens, can you do the following?


Open Applications->Accessories->Passwords and Encryption Keys
If you have an UbuntuOne token (under Passwords: default), right-click and select delete
Open a terminal session (Applications->Accessories->Terminal) and run:
killall ubuntuone-login ubuntuone-syncdaemon
Open System->Preferences->Ubuntu One
A browser window should open and you should be prompted to add your computer

Thank you,

Joshua
The above instructions worked for me. Although for me, I did not have an ubuntuone token, so there was no need for me to delete the key. But still check!

pfnorris
May 3rd, 2010, 01:02 PM
The above instructions worked for me. Although for me, I did not have an ubuntuone token, so there was no need for me to delete the key. But still check!

I have followed these instructions on a fresh build Lucid machine. It gets as far as launching the web browser, and asking me to log in so that I can authorize the machine, but then rejects my credentials with "password didn't match".

I know the credentials are correct 'cause they are working fine with two other upgraded machines. Grateful for any suggestions to solve this little issue.

Phil

pfnorris
May 3rd, 2010, 02:40 PM
I have followed these instructions on a fresh build Lucid machine. It gets as far as launching the web browser, and asking me to log in so that I can authorize the machine, but then rejects my credentials with "password didn't match".

I know the credentials are correct 'cause they are working fine with two other upgraded machines. Grateful for any suggestions to solve this little issue.

Phil

Oh....I feel silly now. "I know the credentials are correct...." Damn those capital letters!!

duanedesign
May 3rd, 2010, 02:47 PM
This worked for me! - Thanks Joshua

Now - If only it would synch my files!

The Ubuntu One Team deployed a whole new infrastructure and server farm to cope with the increasing load. They are in the process of fine-tuning things to take advantage of the new capacity.
Everything should be improving shortly.

BetterWang
May 4th, 2010, 05:34 PM
How come this is not working at all from a new install?

joshuahoover
May 4th, 2010, 09:34 PM
How come this is not working at all from a new install

I'm sorry to hear Ubuntu One isn't working properly for you now. Without more information, I'm not sure how to help you. If your web browser is not opening after opening Ubuntu One Preferences, please see this FAQ: https://wiki.ubuntu.com/UbuntuOne/FAQ#How%20do%20I%20add%20my%20computer?

If you are using the Opera web browser, Ubuntu One will not work.

Thank you,

Joshua

mocabrera
May 5th, 2010, 11:15 PM
Hi, I did this:

https://wiki.ubuntu.com/UbuntuOne/FA...my%20computer? (https://wiki.ubuntu.com/UbuntuOne/FAQ#How%20do%20I%20add%20my%20computer?)

Not working, I have lucid now and I never could add my computer since karmic.
The web page to add computer never shows.

joshuahoover
May 5th, 2010, 11:28 PM
Hi, I did this:

https://wiki.ubuntu.com/UbuntuOne/FA...my%20computer? (https://wiki.ubuntu.com/UbuntuOne/FAQ#How%20do%20I%20add%20my%20computer?)

Not working, I have lucid now and I never could add my computer since karmic.
The web page to add computer never shows.

If you run the following commands in a terminal session, can you tell me what they output?

ubuntuone-preferences

xdg-open https://one.ubuntu.com/

Thank you,

Joshua

mocabrera
May 6th, 2010, 03:24 PM
Thanks for your answer, this is the output:
u1sdtool -q
ubuntuone-syncdaemon stopped.

killall ubuntuone-login
ubuntuone-login: process not found

u1sdtool -c
Nothing happens

Now the others commands:
ubuntuone-preferences: opens the preferences window

xdg-open https://one.ubuntu.com/: open the ubuntu one page, I can sign in ( I have an account) goes directly to the dashboard. In account -> view machines connected:
You haven't added any computers or devices to your Ubuntu One account.

Tell me if you need something else to help solve the problem.

joshuahoover
May 6th, 2010, 08:23 PM
Thanks for your answer, this is the output:
u1sdtool -q
ubuntuone-syncdaemon stopped.

killall ubuntuone-login
ubuntuone-login: process not found

u1sdtool -c
Nothing happens

Now the others commands:
ubuntuone-preferences: opens the preferences window

xdg-open https://one.ubuntu.com/: open the ubuntu one page, I can sign in ( I have an account) goes directly to the dashboard. In account -> view machines connected:
You haven't added any computers or devices to your Ubuntu One account.

Tell me if you need something else to help solve the problem.

I'm sorry this still isn't working for you. It would be helpful to see some log files. Can you file a bug following these steps:

1. https://bugs.edge.launchpad.net/ubuntuone-client/+filebug - Be sure to include the steps you're taking and the results you're seeing
2. At a terminal session (Applications->Accessories->Terminal) run the following command (replacing ###### with the bug number from step 1): apport-collect -p ubuntuone-client ######

Can you make sure you don't have an "Ubuntu One token" in Applications->Accessories->Passwords and Encryption Keys? If you do, can you right-click and select "Delete", then try running the commands you ran previously.

After all that, you can try to run the following script and see if it helps: http://pastebin.ubuntu.com/429028/ To do this, you need to save the script (u1_force_auth.py) to a file and then in a terminal session run the script in the directory where you saved it: python u1_force_auth.py

Thank you,

Joshua

mocabrera
May 6th, 2010, 10:14 PM
Hi I made a bug report #57663, and apport-collect -p ubuntuone-client.

I have not any "Ubuntu One token" in Applications->Accessories->Passwords and Encryption Keys
and if I run http://pastebin.ubuntu.com/429028/ nothing happens, but I have to Ctrl C, to get a prompt.

beameup
May 7th, 2010, 04:51 PM
I'm having a problem with 1 machine getting authenticated.

I get this when I select add this computer. "Firefox can't find the server at localhost."

Thought it might be a firewall issue but it's turned off.
Yes I have a working network connection.
Running 32bit 10.04
I have no U1 token in my keyring
works fine on 2 other machines on the same connection.

Any advice on what to look for?

duanedesign
May 7th, 2010, 06:21 PM
Are you using a proxy or a script blocking application like noScript?

beameup
May 7th, 2010, 06:43 PM
Only Adblock and I turned that off.

OK, I get this in my FF error console.


Bindwood: Error creating database: message: 'Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIXMLHttpRequest.send]', reason: 'undefined', description: 'undefined', error: 'undefined', raw error: '{}'

joshuahoover
May 7th, 2010, 07:44 PM
Only Adblock and I turned that off.

OK, I get this in my FF error console.

It sounds like the local Ubuntu One http server process isn't running. Have you tried this in a terminal session?
u1sdtool -q; killall ubuntuone-login; u1sdtool -c

Thanks!

Joshua

beameup
May 7th, 2010, 07:49 PM
OK solved it. There was no entry in my hosts file for "localhost" only the name of my machine, so I added 127.0.0.1 localhost, and when I retried it all worked.

beameup
May 7th, 2010, 07:51 PM
It sounds like the local Ubuntu One http server process isn't running. Have you tried this in a terminal session?
u1sdtool -q; killall ubuntuone-login; u1sdtool -c

Thanks!

Joshua

Yes Joshua thanks, thats what I've been trying, but see my last post for how i solved it.

mocabrera
May 7th, 2010, 10:12 PM
Hi Joshua, I deleted syncdaemon.conf and the output was:
ubuntuone-syncdaemon stopped.
ubuntuone-login: process not found
And then, the prompt.
Regards


We are following this at https://bugs.launchpad.net/ubuntuone-client/+bug/576636

dafri
May 13th, 2010, 07:32 PM
thank you for this perfekt hint, JOSHUA. this problem is now fixed ;). i take your answer in the german forum (http://forum.ubuntuusers.de/topic/ubuntu-one-probleme-beim-computer-zuordnen/#post-2483037). have i nice evening. greatings from BERLIN! dafri

User Abuser
July 5th, 2010, 06:57 AM
This sounds like you need to remove ~/.config/ubuntuone/syncdaemon.conf and then restart the client. The best way to do this right now is to open a terminal session (Applications->Accessories->Terminal):

killall ubuntuone-syncdaemon
killall ubuntuone-login

Then open System->Preferences->Ubuntu One and see if you get the same error.

Thanks!

Joshua
That worked for me. Thanks Josh :KS This is just great!

duanedesign
July 6th, 2010, 12:48 PM
If you are having trouble adding your computer see:

https://wiki.ubuntu.com/UbuntuOne/FAQ#How%20do%20I%20add%20my%20computer?

not found
October 20th, 2011, 12:10 AM
Back to sleep thread...


404