PDA

View Full Version : [ubuntu] display settings



jdsam
August 26th, 2009, 12:36 AM
Hi, as you guess I am new, but I did search for a solution.
When I set the display to a resolution higher than 800x600 things become fuzzy.
First, I did not have an option to chose a resolution higher than 800x600, but then I searched for some help and I edited some config file and then the Display properties allowed me to chose higher resolution, but when I did things became fuzzy (I know the monitor supports 1024x768).
So, I searched for support for the nvidia card and tried to enabled its drivers, but when I did, after login I got a message about the monitor not being able to display the signal and just got a black screen, so I restarted and restored old settings. Now I am back to the 800x600 option only.
Let me add that my login screen looks very nice. But, when I login, it reverts to 800x600.

Could you help me to get the higher resolution?

Many thanks.

tgeer43
August 26th, 2009, 05:38 AM
You may be trying to use a refresh rate that your monitor does not fully support. Try setting it back to 60Hz to see if that helps.

tgeer

jdsam
August 26th, 2009, 01:51 PM
Many thanks for the reply. It's not the refresh rate. Now things are a bit messier.

The current state is that I think I am running of the driver NVIDIA 173 (this is what appears with green dot next to near when I select System-Hardware Drivers. If I chose the 180 and restart the monitor can not display the signal.

Now, when I select Preferences-Display I get the following message:
"It appears that your graphics driver does not support the necessary extensions to use this tool. Do you want to use your graphics driver vendor's tool instead?"

If I select Yes, I get:
"You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server. "

I have tried this and nothing seems to happen

If I select No, I get the Display Preferences Window with the standard options.
When I change to the higher resolution, things get fuzzy, even at the 60Hz refresh rate.

I appreciate any advice as having an acceptable display is pretty important for day to day usage.

Thanks again.

jdsam
August 26th, 2009, 01:59 PM
And based another post, the result of the command lspci |grep VGA:

nVidia Corporation GeForce 6150SE nForce 430 (rev a2)

jdsam
August 26th, 2009, 02:48 PM
So I have made some progress. By choosing NVIDIA accelerated graphic driver (version 96) I was able to change the setting using the graphic driver vendor's tool.

But, after I change the setting and try to save the config file, I get the message:
"Unable to create new X config backup file '/etc/X11/xorg.conf.backup' "

I manually replaced the contenst of the xorg.conf file but when I restart it reverts to the 800x600.

Any ideas on how to save the change?

This is the content of mu xorg.conf file:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Sun Feb 1 20:21:04 UTC 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "IBM L170p"
HorizSync 30.0 - 81.0
VertRefresh 55.0 - 76.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6100 nForce 430"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "1024x768 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection